> On 10/17/2026 5:16 PM, Lorenzo Bianconi wrote: > > > --- a/drivers/net/wireless/ath/ath12k/core.h > > +++ b/drivers/net/wireless/ath/ath12k/core.h > > @@ -149,6 +149,7 @@ struct ath12k_skb_rxcb { > > u8 tid; > > u16 peer_id; > > bool is_end_of_ppdu; > > + bool reinjected; > > rxcb->is_frag already identifies a reinjected frame, can we use it instead? Hi Baochen, I agree, we can use is_frag and drop reinjected field. I will fix it in v2. > > > > diff --git a/drivers/net/wireless/ath/ath12k/dp_rx.c > b/drivers/net/wireless/ath/ath12k/dp_rx.c > > index 8fa0e90b4531..0003cc5a3720 100644 > > --- a/drivers/net/wireless/ath/ath12k/dp_rx.c > > +++ b/drivers/net/wireless/ath/ath12k/dp_rx.c > > @@ -138,6 +138,7 @@ int ath12k_dp_rx_bufs_replenish(struct ath12k_dp *dp, > > if (!rx_desc) > > goto fail_dma_unmap; > > > > + ATH12K_SKB_RXCB(skb)->reinjected = false; > > These skbs come straight from dev_alloc_skb(), which clears CB area inside, so this is not > required. But for readability purpose I have no objection to keep it. ack, I will drop it in v2. Regards, Lorenzo