From: Alexander Aring <alex.aring@gmail.com>
To: Stefan Schmidt <s.schmidt@samsung.com>
Cc: linux-wpan@vger.kernel.org, kernel@pengutronix.de
Subject: Re: [PATCH bluetooth-next 1/5] at86rf230: remove if branch
Date: Mon, 15 Dec 2014 09:45:40 +0100 [thread overview]
Message-ID: <20141215084538.GC7153@omega> (raw)
In-Reply-To: <250701d01841$3bd6fb30$b384f190$@samsung.com>
On Mon, Dec 15, 2014 at 08:29:24AM +0000, Stefan Schmidt wrote:
> Hello.
>
> On 15/12/14 00:20, Alexander Aring wrote:
> >This patch removes an unnecessary if branch inside the tx complete
> >handler.
> >
> >Signed-off-by: Alexander Aring <alex.aring@gmail.com>
> >---
> > drivers/net/ieee802154/at86rf230.c | 5 +----
> > 1 file changed, 1 insertion(+), 4 deletions(-)
> >
> >diff --git a/drivers/net/ieee802154/at86rf230.c
> >b/drivers/net/ieee802154/at86rf230.c
> >index 1c01356..4e983b3 100644
> >--- a/drivers/net/ieee802154/at86rf230.c
> >+++ b/drivers/net/ieee802154/at86rf230.c
> >@@ -715,10 +715,7 @@ at86rf230_tx_complete(void *context)
> >
> > enable_irq(lp->spi->irq);
> >
> >- if (lp->max_frame_retries <= 0)
> >- ieee802154_xmit_complete(lp->hw, skb, true);
> >- else
> >- ieee802154_xmit_complete(lp->hw, skb, false);
> >+ ieee802154_xmit_complete(lp->hw, skb, lp->max_frame_retries <= 0);
> > }
>
> It surely saves us some lines but personally I find it harder to read this
> way. Having the condition inside the function call breaks the reading flow
> for me. Is this the preferred coding style in the kernel?
>
I agree this is more readable, maybe this is because I wrote this at
first time in this way.
But that reminds me to doing something like this:
if (bool)
return true;
else
return false;
instead:
return bool;
which is usually some beginners failure. I don't know if the kernel
conding style really discuss about that. The checkpatch script doesn't
report anything about this.
Maybe we can put something on the stack like:
bool ifs_handling = lp->max_frame_retries <= 0;
...
ieee802154_xmit_complete(lp->hw, skb, ifs_handling);
is that more readable?
- Alex
next prev parent reply other threads:[~2014-12-15 8:45 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-12-14 23:20 [PATCH bluetooth-next 0/5] at86rf230: cleanups Alexander Aring
2014-12-14 23:20 ` [PATCH bluetooth-next 1/5] at86rf230: remove if branch Alexander Aring
2014-12-15 8:29 ` Stefan Schmidt
2014-12-15 8:45 ` Alexander Aring [this message]
2014-12-15 8:49 ` Alexander Aring
2014-12-14 23:20 ` [PATCH bluetooth-next 2/5] at86rf230: make at86rf230_async_error inline Alexander Aring
2014-12-15 8:29 ` Stefan Schmidt
2014-12-15 8:39 ` Alexander Aring
2014-12-15 9:01 ` Stefan Schmidt
2014-12-15 9:04 ` Alexander Aring
2014-12-14 23:20 ` [PATCH bluetooth-next 3/5] at86rf230: fix context pointer handling Alexander Aring
2014-12-15 8:29 ` Stefan Schmidt
2014-12-14 23:20 ` [PATCH bluetooth-next 4/5] at86rf230: cleanup check on trac status Alexander Aring
2014-12-15 8:29 ` Stefan Schmidt
2014-12-14 23:20 ` [PATCH bluetooth-next 5/5] at86rf230: remove unnecessary assign Alexander Aring
2014-12-15 8:29 ` Stefan Schmidt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20141215084538.GC7153@omega \
--to=alex.aring@gmail.com \
--cc=kernel@pengutronix.de \
--cc=linux-wpan@vger.kernel.org \
--cc=s.schmidt@samsung.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox