From: "Darrick J. Wong" <darrick.wong@oracle.com>
To: Christoph Hellwig <hch@lst.de>
Cc: linux-xfs@vger.kernel.org,
Allison Collins <allison.henderson@oracle.com>
Subject: Re: [PATCH 14/29] xfs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL
Date: Tue, 21 Jan 2020 10:17:52 -0800 [thread overview]
Message-ID: <20200121181752.GN8247@magnolia> (raw)
In-Reply-To: <20200114081051.297488-15-hch@lst.de>
On Tue, Jan 14, 2020 at 09:10:36AM +0100, Christoph Hellwig wrote:
> Use a NULL args->value as the indicator to lazily allocate a buffer
> instead, and let the caller always free args->value instead of
> duplicating the cleanup.
>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
> fs/xfs/libxfs/xfs_attr.c | 20 +++++---------------
> fs/xfs/libxfs/xfs_attr.h | 7 ++-----
> fs/xfs/libxfs/xfs_attr_leaf.c | 2 +-
> fs/xfs/libxfs/xfs_types.h | 2 --
> fs/xfs/xfs_acl.c | 20 ++++++++++----------
> 5 files changed, 18 insertions(+), 33 deletions(-)
>
> diff --git a/fs/xfs/libxfs/xfs_attr.c b/fs/xfs/libxfs/xfs_attr.c
> index 1c4e8ac38d5a..c362dbab1a6a 100644
> --- a/fs/xfs/libxfs/xfs_attr.c
> +++ b/fs/xfs/libxfs/xfs_attr.c
> @@ -98,15 +98,14 @@ xfs_attr_get_ilocked(
> * indication whether the attribute exists and the size of the value if it
> * exists. The size is returned in args.valuelen.
> *
> + * If args->value is NULL but args->valuelen is non-zero, allocate the buffer
> + * for the value after existence of the attribute has been determined. The
> + * caller always has to free args->value if it is set, no matter if this
> + * function was successful or not.
/me wonders if the "null value means alloc buffer internally" (and the
"zero valuelen means return only the value size") behaviors ought to be
documented in the struct xfs_da_args definition?
The code looks fine though.
--D
> + *
> * If the attribute is found, but exceeds the size limit set by the caller in
> * args->valuelen, return -ERANGE with the size of the attribute that was found
> * in args->valuelen.
> - *
> - * If ATTR_ALLOC is set in args->flags, allocate the buffer for the value after
> - * existence of the attribute has been determined. On success, return that
> - * buffer to the caller and leave them to free it. On failure, free any
> - * allocated buffer and ensure the buffer pointer returned to the caller is
> - * null.
> */
> int
> xfs_attr_get(
> @@ -115,8 +114,6 @@ xfs_attr_get(
> uint lock_mode;
> int error;
>
> - ASSERT((args->flags & ATTR_ALLOC) || !args->valuelen || args->value);
> -
> XFS_STATS_INC(args->dp->i_mount, xs_attr_get);
>
> if (XFS_FORCED_SHUTDOWN(args->dp->i_mount))
> @@ -128,18 +125,11 @@ xfs_attr_get(
>
> /* Entirely possible to look up a name which doesn't exist */
> args->op_flags = XFS_DA_OP_OKNOENT;
> - if (args->flags & ATTR_ALLOC)
> - args->op_flags |= XFS_DA_OP_ALLOCVAL;
>
> lock_mode = xfs_ilock_attr_map_shared(args->dp);
> error = xfs_attr_get_ilocked(args);
> xfs_iunlock(args->dp, lock_mode);
>
> - /* on error, we have to clean up allocated value buffers */
> - if (error && (args->flags & ATTR_ALLOC)) {
> - kmem_free(args->value);
> - args->value = NULL;
> - }
> return error;
> }
>
> diff --git a/fs/xfs/libxfs/xfs_attr.h b/fs/xfs/libxfs/xfs_attr.h
> index fe064cd81747..a6de050675c9 100644
> --- a/fs/xfs/libxfs/xfs_attr.h
> +++ b/fs/xfs/libxfs/xfs_attr.h
> @@ -35,10 +35,8 @@ struct xfs_attr_list_context;
>
> #define ATTR_KERNOTIME 0x1000 /* [kernel] don't update inode timestamps */
>
> -#define ATTR_ALLOC 0x8000 /* [kernel] allocate xattr buffer on demand */
> -
> #define ATTR_KERNEL_FLAGS \
> - (ATTR_KERNOTIME | ATTR_ALLOC)
> + (ATTR_KERNOTIME)
>
> #define XFS_ATTR_FLAGS \
> { ATTR_DONTFOLLOW, "DONTFOLLOW" }, \
> @@ -47,8 +45,7 @@ struct xfs_attr_list_context;
> { ATTR_SECURE, "SECURE" }, \
> { ATTR_CREATE, "CREATE" }, \
> { ATTR_REPLACE, "REPLACE" }, \
> - { ATTR_KERNOTIME, "KERNOTIME" }, \
> - { ATTR_ALLOC, "ALLOC" }
> + { ATTR_KERNOTIME, "KERNOTIME" }
>
> /*
> * The maximum size (into the kernel or returned from the kernel) of an
> diff --git a/fs/xfs/libxfs/xfs_attr_leaf.c b/fs/xfs/libxfs/xfs_attr_leaf.c
> index 5e700dfc48a9..b0658eb8fbcc 100644
> --- a/fs/xfs/libxfs/xfs_attr_leaf.c
> +++ b/fs/xfs/libxfs/xfs_attr_leaf.c
> @@ -477,7 +477,7 @@ xfs_attr_copy_value(
> return -ERANGE;
> }
>
> - if (args->op_flags & XFS_DA_OP_ALLOCVAL) {
> + if (!args->value) {
> args->value = kmem_alloc_large(valuelen, 0);
> if (!args->value)
> return -ENOMEM;
> diff --git a/fs/xfs/libxfs/xfs_types.h b/fs/xfs/libxfs/xfs_types.h
> index 634814dd1d10..3379ebc0c7c5 100644
> --- a/fs/xfs/libxfs/xfs_types.h
> +++ b/fs/xfs/libxfs/xfs_types.h
> @@ -223,7 +223,6 @@ typedef struct xfs_da_args {
> #define XFS_DA_OP_ADDNAME 0x0004 /* this is an add operation */
> #define XFS_DA_OP_OKNOENT 0x0008 /* lookup/add op, ENOENT ok, else die */
> #define XFS_DA_OP_CILOOKUP 0x0010 /* lookup to return CI name if found */
> -#define XFS_DA_OP_ALLOCVAL 0x0020 /* lookup to alloc buffer if found */
> #define XFS_DA_OP_INCOMPLETE 0x0040 /* lookup INCOMPLETE attr keys */
>
> #define XFS_DA_OP_FLAGS \
> @@ -232,7 +231,6 @@ typedef struct xfs_da_args {
> { XFS_DA_OP_ADDNAME, "ADDNAME" }, \
> { XFS_DA_OP_OKNOENT, "OKNOENT" }, \
> { XFS_DA_OP_CILOOKUP, "CILOOKUP" }, \
> - { XFS_DA_OP_ALLOCVAL, "ALLOCVAL" }, \
> { XFS_DA_OP_INCOMPLETE, "INCOMPLETE" }
>
> /*
> diff --git a/fs/xfs/xfs_acl.c b/fs/xfs/xfs_acl.c
> index a3c7f86a13e7..89f076e2ed7d 100644
> --- a/fs/xfs/xfs_acl.c
> +++ b/fs/xfs/xfs_acl.c
> @@ -125,7 +125,7 @@ xfs_get_acl(struct inode *inode, int type)
> struct posix_acl *acl = NULL;
> struct xfs_da_args args = {
> .dp = ip,
> - .flags = ATTR_ALLOC | ATTR_ROOT,
> + .flags = ATTR_ROOT,
> .valuelen = XFS_ACL_MAX_SIZE(mp),
> };
> int error;
> @@ -144,19 +144,19 @@ xfs_get_acl(struct inode *inode, int type)
> }
> args.namelen = strlen(args.name);
>
> + /*
> + * If the attribute doesn't exist make sure we have a negative cache
> + * entry, for any other error assume it is transient.
> + */
> error = xfs_attr_get(&args);
> - if (error) {
> - /*
> - * If the attribute doesn't exist make sure we have a negative
> - * cache entry, for any other error assume it is transient.
> - */
> - if (error != -ENOATTR)
> - acl = ERR_PTR(error);
> - } else {
> + if (!error) {
> acl = xfs_acl_from_disk(mp, args.value, args.valuelen,
> XFS_ACL_MAX_ENTRIES(mp));
> - kmem_free(args.value);
> + } else if (error != -ENOATTR) {
> + acl = ERR_PTR(error);
> }
> +
> + kmem_free(args.value);
> return acl;
> }
>
> --
> 2.24.1
>
next prev parent reply other threads:[~2020-01-21 18:17 UTC|newest]
Thread overview: 74+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-01-14 8:10 clean up the attr interface v2 Christoph Hellwig
2020-01-14 8:10 ` [PATCH 01/29] xfs: remove the ATTR_INCOMPLETE flag Christoph Hellwig
2020-01-17 0:59 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 02/29] xfs: merge xfs_attr_remove into xfs_attr_set Christoph Hellwig
2020-01-21 17:28 ` Darrick J. Wong
2020-01-25 4:17 ` Allison Collins
2020-01-25 23:22 ` Christoph Hellwig
2020-01-26 22:23 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 03/29] xfs: merge xfs_attrmulti_attr_remove into xfs_attrmulti_attr_set Christoph Hellwig
2020-01-21 17:41 ` Darrick J. Wong
2020-01-23 22:33 ` Christoph Hellwig
2020-01-14 8:10 ` [PATCH 04/29] xfs: use strndup_user in XFS_IOC_ATTRMULTI_BY_HANDLE Christoph Hellwig
2020-01-21 17:45 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 05/29] xfs: factor out a helper for a single XFS_IOC_ATTRMULTI_BY_HANDLE op Christoph Hellwig
2020-01-21 17:54 ` Darrick J. Wong
2020-01-23 22:34 ` Christoph Hellwig
2020-01-14 8:10 ` [PATCH 06/29] xfs: remove the name == NULL check from xfs_attr_args_init Christoph Hellwig
2020-01-21 17:57 ` Darrick J. Wong
2020-01-23 22:35 ` Christoph Hellwig
2020-01-14 8:10 ` [PATCH 07/29] xfs: remove the MAXNAMELEN " Christoph Hellwig
2020-01-21 18:03 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 08/29] xfs: move struct xfs_da_args to xfs_types.h Christoph Hellwig
2020-01-21 18:48 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 09/29] xfs: turn xfs_da_args.value into a void pointer Christoph Hellwig
2020-01-21 18:07 ` Darrick J. Wong
2020-01-23 22:36 ` Christoph Hellwig
2020-01-14 8:10 ` [PATCH 10/29] xfs: pass an initialized xfs_da_args structure to xfs_attr_set Christoph Hellwig
2020-01-21 18:10 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 11/29] xfs: pass an initialized xfs_da_args to xfs_attr_get Christoph Hellwig
2020-01-21 18:12 ` Darrick J. Wong
2020-01-23 22:39 ` Christoph Hellwig
2020-01-14 8:10 ` [PATCH 12/29] xfs: remove the xfs_inode argument to xfs_attr_get_ilocked Christoph Hellwig
2020-01-21 18:13 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 13/29] xfs: remove ATTR_KERNOVAL Christoph Hellwig
2020-01-21 18:15 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 14/29] xfs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL Christoph Hellwig
2020-01-21 18:17 ` Darrick J. Wong [this message]
2020-01-23 22:40 ` Christoph Hellwig
2020-01-14 8:10 ` [PATCH 15/29] xfs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME Christoph Hellwig
2020-01-21 18:20 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 16/29] xfs: factor out a xfs_attr_match helper Christoph Hellwig
2020-01-21 18:27 ` Darrick J. Wong
2020-01-23 22:41 ` Christoph Hellwig
2020-01-14 8:10 ` [PATCH 17/29] xfs: cleanup xfs_attr_list_context Christoph Hellwig
2020-01-21 18:30 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 18/29] xfs: remove the unused ATTR_ENTRY macro Christoph Hellwig
2020-01-21 18:33 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 19/29] xfs: replace ATTR_ENTBASESIZE with offsetoff Christoph Hellwig
2020-01-21 18:36 ` Darrick J. Wong
2020-01-23 22:43 ` Christoph Hellwig
2020-01-14 8:10 ` [PATCH 20/29] xfs: move the legacy xfs_attr_list to xfs_ioctl.c Christoph Hellwig
2020-01-21 18:41 ` Darrick J. Wong
2020-01-24 23:13 ` Christoph Hellwig
2020-01-14 8:10 ` [PATCH 21/29] xfs: rename xfs_attr_list_int to xfs_attr_list Christoph Hellwig
2020-01-21 18:42 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 22/29] xfs: lift common checks into xfs_ioc_attr_list Christoph Hellwig
2020-01-21 18:43 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 23/29] xfs: lift buffer allocation " Christoph Hellwig
2020-01-21 18:49 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 24/29] xfs: lift cursor copy in/out " Christoph Hellwig
2020-01-21 18:52 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 25/29] xfs: improve xfs_forget_acl Christoph Hellwig
2020-01-21 18:56 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 26/29] xfs: clean up the ATTR_REPLACE checks Christoph Hellwig
2020-01-21 18:57 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 27/29] xfs: clean up the attr flag confusion Christoph Hellwig
2020-01-21 19:44 ` Darrick J. Wong
2020-01-24 23:24 ` Christoph Hellwig
2020-01-25 23:10 ` Christoph Hellwig
2020-01-26 22:24 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 28/29] xfs: remove XFS_DA_OP_INCOMPLETE Christoph Hellwig
2020-01-21 19:45 ` Darrick J. Wong
2020-01-14 8:10 ` [PATCH 29/29] xfs: embedded the attrlist cursor into struct xfs_attr_list_context Christoph Hellwig
2020-01-21 19:04 ` Darrick J. Wong
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200121181752.GN8247@magnolia \
--to=darrick.wong@oracle.com \
--cc=allison.henderson@oracle.com \
--cc=hch@lst.de \
--cc=linux-xfs@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox