From: Carlos Maiolino <cem@kernel.org>
To: "Darrick J. Wong" <djwong@kernel.org>
Cc: linux-xfs@vger.kernel.org
Subject: Re: [PATCH] libxfs: fix confusing xfs_extent_item variable names
Date: Thu, 11 May 2023 15:35:28 +0200 [thread overview]
Message-ID: <20230511133528.wtunsuolh4hms36b@andromeda> (raw)
In-Reply-To: <20230510195617.GD858799@frogsfrogsfrogs>
On Wed, May 10, 2023 at 12:56:17PM -0700, Darrick J. Wong wrote:
> From: Darrick J. Wong <djwong@kernel.org>
>
> Change the name of all pointers to xfs_extent_item structures to "xefi"
> to make the name consistent and because the current selections ("new"
> and "free") mean other things in C.
>
> Signed-off-by: Darrick J. Wong <djwong@kernel.org>
Sounds good, thanks!
Reviewed-by: Carlos Maiolino <cmaiolino@redhat.com>
> ---
> libxfs/defer_item.c | 41 +++++++++++++++++++++++------------------
> 1 file changed, 23 insertions(+), 18 deletions(-)
>
> diff --git a/libxfs/defer_item.c b/libxfs/defer_item.c
> index b95b54e5..2e9912f8 100644
> --- a/libxfs/defer_item.c
> +++ b/libxfs/defer_item.c
> @@ -80,18 +80,20 @@ xfs_extent_free_finish_item(
> struct xfs_btree_cur **state)
> {
> struct xfs_owner_info oinfo = { };
> - struct xfs_extent_free_item *free;
> + struct xfs_extent_free_item *xefi;
> int error;
>
> - free = container_of(item, struct xfs_extent_free_item, xefi_list);
> - oinfo.oi_owner = free->xefi_owner;
> - if (free->xefi_flags & XFS_EFI_ATTR_FORK)
> + xefi = container_of(item, struct xfs_extent_free_item, xefi_list);
> +
> + oinfo.oi_owner = xefi->xefi_owner;
> + if (xefi->xefi_flags & XFS_EFI_ATTR_FORK)
> oinfo.oi_flags |= XFS_OWNER_INFO_ATTR_FORK;
> - if (free->xefi_flags & XFS_EFI_BMBT_BLOCK)
> + if (xefi->xefi_flags & XFS_EFI_BMBT_BLOCK)
> oinfo.oi_flags |= XFS_OWNER_INFO_BMBT_BLOCK;
> - error = xfs_free_extent(tp, free->xefi_startblock,
> - free->xefi_blockcount, &oinfo, XFS_AG_RESV_NONE);
> - kmem_cache_free(xfs_extfree_item_cache, free);
> + error = xfs_free_extent(tp, xefi->xefi_startblock,
> + xefi->xefi_blockcount, &oinfo, XFS_AG_RESV_NONE);
> +
> + kmem_cache_free(xfs_extfree_item_cache, xefi);
> return error;
> }
>
> @@ -107,10 +109,11 @@ STATIC void
> xfs_extent_free_cancel_item(
> struct list_head *item)
> {
> - struct xfs_extent_free_item *free;
> + struct xfs_extent_free_item *xefi;
>
> - free = container_of(item, struct xfs_extent_free_item, xefi_list);
> - kmem_cache_free(xfs_extfree_item_cache, free);
> + xefi = container_of(item, struct xfs_extent_free_item, xefi_list);
> +
> + kmem_cache_free(xfs_extfree_item_cache, xefi);
> }
>
> const struct xfs_defer_op_type xfs_extent_free_defer_type = {
> @@ -134,25 +137,27 @@ xfs_agfl_free_finish_item(
> {
> struct xfs_owner_info oinfo = { };
> struct xfs_mount *mp = tp->t_mountp;
> - struct xfs_extent_free_item *free;
> + struct xfs_extent_free_item *xefi;
> struct xfs_buf *agbp;
> struct xfs_perag *pag;
> int error;
> xfs_agnumber_t agno;
> xfs_agblock_t agbno;
>
> - free = container_of(item, struct xfs_extent_free_item, xefi_list);
> - ASSERT(free->xefi_blockcount == 1);
> - agno = XFS_FSB_TO_AGNO(mp, free->xefi_startblock);
> - agbno = XFS_FSB_TO_AGBNO(mp, free->xefi_startblock);
> - oinfo.oi_owner = free->xefi_owner;
> + xefi = container_of(item, struct xfs_extent_free_item, xefi_list);
> +
> + ASSERT(xefi->xefi_blockcount == 1);
> + agno = XFS_FSB_TO_AGNO(mp, xefi->xefi_startblock);
> + agbno = XFS_FSB_TO_AGBNO(mp, xefi->xefi_startblock);
> + oinfo.oi_owner = xefi->xefi_owner;
>
> pag = libxfs_perag_get(mp, agno);
> error = xfs_alloc_read_agf(pag, tp, 0, &agbp);
> if (!error)
> error = xfs_free_agfl_block(tp, agno, agbno, agbp, &oinfo);
> libxfs_perag_put(pag);
> - kmem_cache_free(xfs_extfree_item_cache, free);
> +
> + kmem_cache_free(xfs_extfree_item_cache, xefi);
> return error;
> }
>
--
Carlos Maiolino
prev parent reply other threads:[~2023-05-11 13:38 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <0kaspVe46GjWH34UplQpBKZYm9TFMd-VCgmBlNr5UbWao_BKBsNdO8xn06_SqVveitqg5wLOXPd-St5SXH5Aag==@protonmail.internalid>
2023-05-10 19:56 ` [PATCH] libxfs: fix confusing xfs_extent_item variable names Darrick J. Wong
2023-05-11 13:35 ` Carlos Maiolino [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230511133528.wtunsuolh4hms36b@andromeda \
--to=cem@kernel.org \
--cc=djwong@kernel.org \
--cc=linux-xfs@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox