From: Christoph Hellwig <hch@lst.de>
To: Carlos Maiolino <cem@kernel.org>
Cc: Andrey Albershteyn <aalbersh@kernel.org>,
"Darrick J . Wong" <djwong@kernel.org>,
Dave Chinner <david@fromorbit.com>,
Eric Sandeen <sandeen@redhat.com>,
linux-xfs@vger.kernel.org
Subject: [PATCH 3/4] xfs: move the remaining content from xfs.h to xfs_platform.h
Date: Fri, 19 Dec 2025 06:41:46 +0100 [thread overview]
Message-ID: <20251219054202.1773441-4-hch@lst.de> (raw)
In-Reply-To: <20251219054202.1773441-1-hch@lst.de>
Move the global defines from xfs.h to xfs_platform.h to prepare for
removing xfs.h.
Signed-off-by: Christoph Hellwig <hch@lst.de>
---
fs/xfs/xfs.h | 17 -----------------
fs/xfs/xfs_platform.h | 16 ++++++++++++++++
2 files changed, 16 insertions(+), 17 deletions(-)
diff --git a/fs/xfs/xfs.h b/fs/xfs/xfs.h
index b335a471c088..3ec52f2ec4b2 100644
--- a/fs/xfs/xfs.h
+++ b/fs/xfs/xfs.h
@@ -6,23 +6,6 @@
#ifndef __XFS_H__
#define __XFS_H__
-#ifdef CONFIG_XFS_DEBUG
-#define DEBUG 1
-#endif
-
-#ifdef CONFIG_XFS_DEBUG_EXPENSIVE
-#define DEBUG_EXPENSIVE 1
-#endif
-
-#ifdef CONFIG_XFS_ASSERT_FATAL
-#define XFS_ASSERT_FATAL 1
-#endif
-
-#ifdef CONFIG_XFS_WARN
-#define XFS_WARN 1
-#endif
-
-
#include "xfs_platform.h"
#endif /* __XFS_H__ */
diff --git a/fs/xfs/xfs_platform.h b/fs/xfs/xfs_platform.h
index 5223fe567ac1..c7b013593646 100644
--- a/fs/xfs/xfs_platform.h
+++ b/fs/xfs/xfs_platform.h
@@ -57,6 +57,22 @@
#include <asm/byteorder.h>
#include <linux/unaligned.h>
+#ifdef CONFIG_XFS_DEBUG
+#define DEBUG 1
+#endif
+
+#ifdef CONFIG_XFS_DEBUG_EXPENSIVE
+#define DEBUG_EXPENSIVE 1
+#endif
+
+#ifdef CONFIG_XFS_ASSERT_FATAL
+#define XFS_ASSERT_FATAL 1
+#endif
+
+#ifdef CONFIG_XFS_WARN
+#define XFS_WARN 1
+#endif
+
/*
* Kernel specific type declarations for XFS
*/
--
2.47.3
next prev parent reply other threads:[~2025-12-19 5:42 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-12-19 5:41 [PATCH v2] rename xfs.h Christoph Hellwig
2025-12-19 5:41 ` [PATCH 1/4] xfs: rename xfs_linux.h to xfs_platform.h Christoph Hellwig
2025-12-19 5:41 ` [PATCH 2/4] xfs: include global headers first in xfs_platform.h Christoph Hellwig
2025-12-19 5:41 ` Christoph Hellwig [this message]
2025-12-19 5:41 ` [PATCH 4/4] xfs: directly include xfs_platform.h Christoph Hellwig
2025-12-19 23:53 ` [PATCH v2] rename xfs.h Darrick J. Wong
2026-01-09 12:03 ` Carlos Maiolino
2026-01-09 15:03 ` Carlos Maiolino
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20251219054202.1773441-4-hch@lst.de \
--to=hch@lst.de \
--cc=aalbersh@kernel.org \
--cc=cem@kernel.org \
--cc=david@fromorbit.com \
--cc=djwong@kernel.org \
--cc=linux-xfs@vger.kernel.org \
--cc=sandeen@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox