Linux XFS filesystem development
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Carlos Maiolino <cem@kernel.org>
Cc: linux-xfs@vger.kernel.org
Subject: [PATCH 02/16] xfs: rename xfs_ioc_swapext to xfs_swapext
Date: Wed, 29 Jul 2026 15:03:01 +0200	[thread overview]
Message-ID: <20260729130320.2282183-3-hch@lst.de> (raw)
In-Reply-To: <20260729130320.2282183-1-hch@lst.de>

The usual convention is that the ioc_ prefix is used for direct ioctl
handlers that take a user pointer.  The current xfs_ioc_swapext does not
fit that pattern, so rename it.

Signed-off-by: Christoph Hellwig <hch@lst.de>
---
 fs/xfs/xfs_ioctl.c   | 8 ++++----
 fs/xfs/xfs_ioctl.h   | 4 +---
 fs/xfs/xfs_ioctl32.c | 2 +-
 3 files changed, 6 insertions(+), 8 deletions(-)

diff --git a/fs/xfs/xfs_ioctl.c b/fs/xfs/xfs_ioctl.c
index ec5412a9eb1d..9a10645f5222 100644
--- a/fs/xfs/xfs_ioctl.c
+++ b/fs/xfs/xfs_ioctl.c
@@ -962,10 +962,10 @@ xfs_ioc_getbmap(
 }
 
 int
-xfs_ioc_swapext(
-	xfs_swapext_t	*sxp)
+xfs_swapext(
+	struct xfs_swapext	*sxp)
 {
-	xfs_inode_t     *ip, *tip;
+	struct xfs_inode	*ip, *tip;
 
 	/* Pull information for the target fd */
 	CLASS(fd, f)((int)sxp->sx_fdtarget);
@@ -1341,7 +1341,7 @@ xfs_file_ioctl(
 		error = mnt_want_write_file(filp);
 		if (error)
 			return error;
-		error = xfs_ioc_swapext(&sxp);
+		error = xfs_swapext(&sxp);
 		mnt_drop_write_file(filp);
 		return error;
 	}
diff --git a/fs/xfs/xfs_ioctl.h b/fs/xfs/xfs_ioctl.h
index f5ed5cf9d3df..e57d8f5148bf 100644
--- a/fs/xfs/xfs_ioctl.h
+++ b/fs/xfs/xfs_ioctl.h
@@ -10,9 +10,7 @@ struct xfs_bstat;
 struct xfs_ibulk;
 struct xfs_inogrp;
 
-int
-xfs_ioc_swapext(
-	xfs_swapext_t	*sxp);
+int xfs_swapext(struct xfs_swapext *sxp);
 
 extern int
 xfs_fileattr_get(
diff --git a/fs/xfs/xfs_ioctl32.c b/fs/xfs/xfs_ioctl32.c
index c66e192448a8..250df2bbf214 100644
--- a/fs/xfs/xfs_ioctl32.c
+++ b/fs/xfs/xfs_ioctl32.c
@@ -475,7 +475,7 @@ xfs_file_compat_ioctl(
 		error = mnt_want_write_file(filp);
 		if (error)
 			return error;
-		error = xfs_ioc_swapext(&sxp);
+		error = xfs_swapext(&sxp);
 		mnt_drop_write_file(filp);
 		return error;
 	}
-- 
2.53.0


  parent reply	other threads:[~2026-07-29 13:03 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-29 13:02 xfs ioctl handler cleanups Christoph Hellwig
2026-07-29 13:03 ` [PATCH 01/16] xfs: remove an outdated comment above xfs_file_ioctl Christoph Hellwig
2026-07-29 13:03 ` Christoph Hellwig [this message]
2026-07-29 13:03 ` [PATCH 03/16] xfs: rename xfs_ioctl_fs_counts to xfs_ioc_fs_counts Christoph Hellwig
2026-07-29 13:03 ` [PATCH 04/16] xfs: rename xfs_ioctl_getset_resblocks to xfs_ioc_getset_resblocks Christoph Hellwig
2026-07-29 13:03 ` [PATCH 05/16] xfs: split out the handler for XFS_IOC_DIOINFO Christoph Hellwig
2026-07-29 13:03 ` [PATCH 06/16] xfs: split out the handlers for XFS_IOC_.*HANDLE Christoph Hellwig
2026-07-29 13:03 ` [PATCH 07/16] xfs: split out the handler for XFS_IOC_SWAPEXT Christoph Hellwig
2026-07-29 13:03 ` [PATCH 08/16] xfs: split out the handlers for XFS_IOC_FSGROWFS* Christoph Hellwig
2026-07-29 13:03 ` [PATCH 09/16] xfs: split out the handler for XFS_IOC_GOINGDOWN Christoph Hellwig
2026-07-29 13:03 ` [PATCH 10/16] xfs: split out the handler for XFS_IOC_ERROR_INJECTION Christoph Hellwig
2026-07-29 13:03 ` [PATCH 11/16] xfs: split out the handler for XFS_IOC_FREE_EOFBLOCKS Christoph Hellwig
2026-07-29 13:03 ` [PATCH 12/16] xfs: split out the handlers for XFS_IOC_FSGROWFS_*_32 Christoph Hellwig
2026-07-29 13:03 ` [PATCH 13/16] xfs: cleanup XFS_IOC_GETVERSION_32 handling Christoph Hellwig
2026-07-29 13:03 ` [PATCH 14/16] xfs: split out the handlers for XFS_IOC_SWAPEXT_32 Christoph Hellwig
2026-07-29 13:03 ` [PATCH 15/16] xfs: split out the handlers for XFS_IOC_*_BY_HANDLE_32 Christoph Hellwig
2026-07-29 13:03 ` [PATCH 16/16] xfs: remove an extra cast in xfs_file_compat_ioctl Christoph Hellwig
2026-07-29 15:29 ` xfs ioctl handler cleanups Darrick J. Wong
  -- strict thread matches above, loose matches on Subject: below --
2026-07-29 11:39 Christoph Hellwig
2026-07-29 11:39 ` [PATCH 02/16] xfs: rename xfs_ioc_swapext to xfs_swapext Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260729130320.2282183-3-hch@lst.de \
    --to=hch@lst.de \
    --cc=cem@kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox