Linux XFS filesystem development
 help / color / mirror / Atom feed
 messages from 2025-07-03 12:17:00 to 2025-07-12 14:14:19 UTC [more...]

[PATCH v3 00/13] Add more tests for multi fs block atomic writes
 2025-07-12 14:12 UTC  (14+ messages)
` [PATCH v3 01/13] common/rc: Add _min() and _max() helpers
` [PATCH v3 02/13] common/rc: Fix fsx for ext4 with bigalloc
` [PATCH v3 03/13] common/rc: Add a helper to run fsx on a given file
` [PATCH v3 04/13] ltp/fsx.c: Add atomic writes support to fsx
` [PATCH v3 05/13] generic/1226: Add atomic write test using fio crc check verifier
` [PATCH v3 06/13] generic/1227: Add atomic write test using fio verify on file mixed mappings
` [PATCH v3 07/13] generic/1228: Add atomic write multi-fsblock O_[D]SYNC tests
` [PATCH v3 08/13] generic/1229: Stress fsx with atomic writes enabled
` [PATCH v3 09/13] generic/1230: Add sudden shutdown tests for multi block atomic writes
` [PATCH v3 10/13] ext4/061: Atomic writes stress test for bigalloc using fio crc verifier
` [PATCH v3 11/13] ext4/062: Atomic writes test for bigalloc using fio crc verifier on multiple files
` [PATCH v3 12/13] ext4/063: Atomic write test for extent split across leaf nodes
` [PATCH v3 13/13] ext4/064: Add atomic write tests for journal credit calculation

Query: XFS reflink unique block measurement / snapshot accounting
 2025-07-12  7:49 UTC 

[PATCH v2] fs/xfs: replace strncpy with memtostr_pad()
 2025-07-12  5:56 UTC  (3+ messages)

[PATCH v4 1/6] fs: enhance and rename shutdown() callback to remove_bdev()
 2025-07-11 14:20 UTC  (5+ messages)

[PATCH v7 0/6] block/md/dm: set chunk_sectors from stacked dev stripe size
 2025-07-11 11:43 UTC  (8+ messages)
` [PATCH v7 1/6] ilog2: add max_pow_of_two_factor()
` [PATCH v7 2/6] block: sanitize chunk_sectors for atomic write limits
` [PATCH v7 3/6] md/raid0: set chunk_sectors limit
` [PATCH v7 4/6] md/raid10: "
` [PATCH v7 5/6] dm-stripe: limit chunk_sectors to the stripe size
` [PATCH v7 6/6] block: use chunk_sectors when evaluating stacked atomic write limits

refactor the iomap writeback code v5
 2025-07-11 11:20 UTC  (17+ messages)
` [PATCH 01/14] iomap: header diet
` [PATCH 02/14] iomap: pass more arguments using the iomap writeback context
` [PATCH 03/14] iomap: cleanup the pending writeback tracking in iomap_writepage_map_blocks
` [PATCH 04/14] iomap: refactor the writeback interface
` [PATCH 05/14] iomap: hide ioends from the generic writeback code
` [PATCH 06/14] iomap: add public helpers for uptodate state manipulation
` [PATCH 07/14] iomap: move all ioend handling to ioend.c
` [PATCH 08/14] iomap: rename iomap_writepage_map to iomap_writeback_folio
` [PATCH 09/14] iomap: move folio_unlock out of iomap_writeback_folio
` [PATCH 10/14] iomap: export iomap_writeback_folio
` [PATCH 11/14] iomap: replace iomap_folio_ops with iomap_write_ops
` [PATCH 12/14] iomap: improve argument passing to iomap_read_folio_sync
` [PATCH 13/14] iomap: add read_folio_range() handler for buffered writes
` [PATCH 14/14] iomap: build the writeback code without CONFIG_BLOCK

[PATCH v4 1/6] fs: enhance and rename shutdown() callback to remove_bdev()
 2025-07-11  9:34 UTC  (25+ messages)
  ` (subset) "

[PATCH v6 0/6] block/md/dm: set chunk_sectors from stacked dev stripe size
 2025-07-11  9:22 UTC  (11+ messages)
` [PATCH v6 1/6] ilog2: add max_pow_of_two_factor()
` [PATCH v6 2/6] block: sanitize chunk_sectors for atomic write limits
` [PATCH v6 3/6] md/raid0: set chunk_sectors limit
` [PATCH v6 4/6] md/raid10: "
` [PATCH v6 5/6] dm-stripe: limit chunk_sectors to the stripe size
` [PATCH v6 6/6] block: use chunk_sectors when evaluating stacked atomic write limits

[PATCH v2] iomap: avoid unnecessary ifs_set_range_uptodate() with locks
 2025-07-11  8:13 UTC  (2+ messages)

[PATCH] iomap: avoid unnecessary ifs_set_range_uptodate() with locks
 2025-07-11  7:44 UTC  (6+ messages)

[PATCHSET 1/2] fstests: check new 6.15 behaviors
 2025-07-10 18:26 UTC  (3+ messages)

[PATCH v5 0/6] block/md/dm: set chunk_sectors from stacked dev stripe size
 2025-07-10 15:29 UTC  (11+ messages)
` [PATCH v5 1/6] ilog2: add max_pow_of_two_factor()
` [PATCH v5 2/6] block: sanitize chunk_sectors for atomic write limits
` [PATCH v5 3/6] md/raid0: set chunk_sectors limit
` [PATCH v5 4/6] md/raid10: "
` [PATCH v5 5/6] dm-stripe: limit chunk_sectors to the stripe size
` [PATCH v5 6/6] block: use chunk_sectors when evaluating stacked atomic write limits

[syzbot] [xfs?] possible deadlock in xfs_ilock_attr_map_shared (2)
 2025-07-10  8:02 UTC  (4+ messages)

[syzbot] [xfs?] INFO: task hung in xfs_file_fsync
 2025-07-10  0:44 UTC  (2+ messages)

refactor the iomap writeback code v4
 2025-07-09 17:53 UTC  (27+ messages)
` [PATCH 01/14] iomap: header diet
` [PATCH 02/14] iomap: pass more arguments using the iomap writeback context
` [PATCH 03/14] iomap: cleanup the pending writeback tracking in iomap_writepage_map_blocks
` [PATCH 04/14] iomap: refactor the writeback interface
` [PATCH 05/14] iomap: hide ioends from the generic writeback code
` [PATCH 06/14] iomap: add public helpers for uptodate state manipulation
` [PATCH 07/14] iomap: move all ioend handling to ioend.c
` [PATCH 08/14] iomap: rename iomap_writepage_map to iomap_writeback_folio
` [PATCH 09/14] iomap: move folio_unlock out of iomap_writeback_folio
` [PATCH 10/14] iomap: export iomap_writeback_folio
` [PATCH 11/14] iomap: replace iomap_folio_ops with iomap_write_ops
` [PATCH 12/14] iomap: improve argument passing to iomap_read_folio_sync
` [PATCH 13/14] iomap: add read_folio_range() handler for buffered writes
` [PATCH 14/14] iomap: build the writeback code without CONFIG_BLOCK

[syzbot] [xfs?] INFO: task hung in xfs_setfilesize
 2025-07-09 17:38 UTC 

[PATCHSET 2/3] xfsprogs: atomic writes
 2025-07-09 16:45 UTC  (11+ messages)
` [PATCH 2/7] xfs_db: create an untorn_max subcommand
` [PATCH 4/7] mkfs: don't complain about overly large auto-detected log stripe units
` [PATCH 5/7] mkfs: autodetect log stripe unit for external log devices

[PATCH v2 00/13] xfs: tracing: remove unused event xfs_reflink_cow_found
 2025-07-09 14:55 UTC  (5+ messages)

[PATCH v4 0/6] block/md/dm: set chunk_sectors from stacked dev stripe size
 2025-07-08 18:00 UTC  (11+ messages)
` [PATCH v4 1/6] ilog2: add max_pow_of_two_factor()
` [PATCH v4 2/6] block: sanitize chunk_sectors for atomic write limits
` [PATCH v4 3/6] md/raid0: set chunk_sectors limit
` [PATCH v4 4/6] md/raid10: "
` [PATCH v4 5/6] dm-stripe: limit chunk_sectors to the stripe size
` [PATCH v4 6/6] block: use chunk_sectors when evaluating stacked atomic write limits

[PATCH v2 0/6] xfs: cleanup key comparing routines
 2025-07-08 12:00 UTC  (2+ messages)

misc cleanups v3
 2025-07-08 12:00 UTC  (8+ messages)
` [PATCH 1/5] xfs: clean up the initial read logic in xfs_readsb
` [PATCH 2/5] xfs: remove the call to sync_blockdev in xfs_configure_buftarg
` [PATCH 3/5] xfs: add a xfs_group_type_buftarg helper
` [PATCH 4/5] xfs: refactor xfs_calc_atomic_write_unit_max
` [PATCH 5/5] xfs: rename the bt_bdev_* buftarg fields
` [PATCH 6/5] xfs: remove the bt_bdev_file buftarg field

[PATCH] xfs: replace strncpy with memcpy in xattr listing
 2025-07-08 12:00 UTC  (8+ messages)

[ANNOUNCE] xfs-linux: for-next updated to 1928a4228b2f
 2025-07-08 11:56 UTC 

[syzbot] [mm?] WARNING in xfs_init_fs_context
 2025-07-08  9:48 UTC  (6+ messages)

[PATCH v6 0/6] fs: introduce file_getattr and file_setattr syscalls
 2025-07-07 12:27 UTC  (15+ messages)
` [PATCH v6 6/6] "

[PATCH] fs/xfs: replace strncpy with memtostr_pad()
 2025-07-04  9:52 UTC  (3+ messages)

[PATCH v3 1/6] fs: enhance and rename shutdown() callback to remove_bdev()
 2025-07-04  9:01 UTC  (2+ messages)

[PATCH v2 0/9] fallocate: introduce FALLOC_FL_WRITE_ZEROES flag
 2025-07-04  8:39 UTC  (4+ messages)

[PATCH v3 00/16] fuse: use iomap for buffered writes + writeback
 2025-07-03 16:51 UTC  (8+ messages)
` [PATCH v3 03/16] iomap: refactor the writeback interface
` [PATCH v3 04/16] iomap: hide ioends from the generic writeback code

[GIT PULL] XFS fixes for v6.16-rc5
 2025-07-03 16:31 UTC  (3+ messages)

[PATCH] iomap: avoid unnecessary ifs_set_range_uptodate() with locks
 2025-07-03 14:33 UTC  (4+ messages)

[PATCHSET 3/3] xfs_scrub: drop EXPERIMENTAL warning
 2025-07-03 13:45 UTC  (3+ messages)
` [PATCH 1/1] xfs_scrub: remove EXPERIMENTAL warnings

misc cleanups v2
 2025-07-03 13:44 UTC  (7+ messages)
` [PATCH 2/7] xfs: remove the call to sync_blockdev in xfs_configure_buftarg
` [PATCH 7/7] xfs: remove the bt_meta_sectorsize field in struct buftarg


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox