From: Kyle Moffett <Kyle.D.Moffett@boeing.com>
To: linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org
Cc: Kyle Moffett <Kyle.D.Moffett@boeing.com>
Subject: [RFC PATCH 00/10] powerpc/mpic: General cleanup patch series
Date: Mon, 31 Oct 2011 17:10:01 -0400 [thread overview]
Message-ID: <1320095411-20667-1-git-send-email-Kyle.D.Moffett@boeing.com> (raw)
Hello,
I've been tinkering with a series of patches to clean up the PowerPC
MPIC/OpenPIC init recently as part of a new board port I'm working on.
It's reached the point where I'd like some feedback on the general
approach. The code itself hasn't been tested at all yet, and probably
does not compile right now (though that is my next step).
(Oh, actually, the first patch isn't really even about the MPIC code,
it should probably be reviewed on its own; oh well...)
Please let me know what you think.
Cheers,
Kyle Moffett
--
Curious about my work on the Debian powerpcspe port?
I'm keeping a blog here: http://pureperl.blogspot.com/
next reply other threads:[~2011-10-31 21:11 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-10-31 21:10 Kyle Moffett [this message]
2011-10-31 21:10 ` [RFC PATCH 01/10] powerpc/85xx: Move mpc85xx_smp_init() decl to a new "smp.h" Kyle Moffett
2011-10-31 21:10 ` [RFC PATCH 02/10] powerpc: Consolidate mpic_alloc() OF address translation Kyle Moffett
2011-10-31 21:10 ` [RFC PATCH 03/10] powerpc/mpic: Assume a device-node was passed in mpic_alloc() Kyle Moffett
2011-10-31 21:10 ` [RFC PATCH 04/10] powerpc/mpic: Save computed phys_addr for board-specific code Kyle Moffett
2011-10-31 21:10 ` [RFC PATCH 05/10] powerpc/mpic: Search for open-pic device-tree node if NULL Kyle Moffett
2011-10-31 21:10 ` [RFC PATCH 06/10] powerpc/mpic: Invert the meaning of MPIC_PRIMARY Kyle Moffett
2011-10-31 21:10 ` [RFC PATCH 07/10] powerpc/mpic: Don't open-code dcr_resource_start Kyle Moffett
2011-10-31 21:10 ` [RFC PATCH 08/10] powerpc/mpic: Put "pic-no-reset" test back into the MPIC code Kyle Moffett
2011-10-31 21:10 ` [RFC PATCH 09/10] powerpc/mpic: Cache the device-tree node in "struct mpic" Kyle Moffett
2011-10-31 21:10 ` [RFC PATCH 10/10] powerpc/mpic: Add in-core support for cascaded MPICs Kyle Moffett
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1320095411-20667-1-git-send-email-Kyle.D.Moffett@boeing.com \
--to=kyle.d.moffett@boeing.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linuxppc-dev@lists.ozlabs.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox