From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from eu1sys200aog116.obsmtp.com (eu1sys200aog116.obsmtp.com [207.126.144.141]) (using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)) (Client did not present a certificate) by ozlabs.org (Postfix) with ESMTPS id DAE0E2C008B for ; Fri, 14 Sep 2012 18:50:35 +1000 (EST) From: Srinivas KANDAGATLA To: benh@kernel.crashing.org, bergner@us.ibm.com Subject: [PATCH v2 2/7] dt/powerpc: Use of_get_child_by_name to get a named child. Date: Fri, 14 Sep 2012 09:18:44 +0100 Message-Id: <1347610724-20152-1-git-send-email-srinivas.kandagatla@st.com> Cc: robherring2@gmail.com, devicetree-discuss@lists.ozlabs.org, linuxppc-dev@lists.ozlabs.org, srinivas.kandagatla@st.com List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc/kernel/prom.c | 5 +---- 1 files changed, 1 insertions(+), 4 deletions(-) diff --git a/arch/powerpc/kernel/prom.c b/arch/powerpc/kernel/prom.c index f191bf0..80e5b6c 100644 --- a/arch/powerpc/kernel/prom.c +++ b/arch/powerpc/kernel/prom.c @@ -735,7 +735,6 @@ void __init early_init_devtree(void *params) */ struct device_node *of_find_next_cache_node(struct device_node *np) { - struct device_node *child; const phandle *handle; handle = of_get_property(np, "l2-cache", NULL); @@ -749,9 +748,7 @@ struct device_node *of_find_next_cache_node(struct device_node *np) * beneath CPU nodes. */ if (!strcmp(np->type, "cpu")) - for_each_child_of_node(np, child) - if (!strcmp(child->type, "cache")) - return child; + return of_get_child_by_name(np, "cache"); return NULL; } -- 1.7.0.4