From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: From: Srinivas KANDAGATLA To: benh@kernel.crashing.org Subject: [PATCH v3 2/5] dt/powerpc/powernv: Use of_get_child_by_name to get a named child. Date: Mon, 17 Sep 2012 09:57:40 +0100 Message-Id: <1347872260-3707-1-git-send-email-srinivas.kandagatla@st.com> Cc: robherring2@gmail.com, devicetree-discuss@lists.ozlabs.org, linuxppc-dev@lists.ozlabs.org, srinivas.kandagatla@st.com List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc/platforms/powernv/opal.c | 6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff --git a/arch/powerpc/platforms/powernv/opal.c b/arch/powerpc/platforms/powernv/opal.c index aaa0dba..fc7ae70 100644 --- a/arch/powerpc/platforms/powernv/opal.c +++ b/arch/powerpc/platforms/powernv/opal.c @@ -294,9 +294,9 @@ static int __init opal_init(void) consoles = of_node_get(opal_node); /* Register serial ports */ - for_each_child_of_node(consoles, np) { - if (strcmp(np->name, "serial")) - continue; + np = of_get_child_by_name(consoles, "serial"); + if (np) { + of_node_put(np); of_platform_device_create(np, NULL, NULL); } of_node_put(consoles); -- 1.7.0.4