From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: From: Srinivas KANDAGATLA To: benh@kernel.crashing.org Subject: [PATCH v3 3/5] dt/powerpc/sysdev: Use of_get_child_by_name to get a named child. Date: Mon, 17 Sep 2012 09:57:52 +0100 Message-Id: <1347872272-3741-1-git-send-email-srinivas.kandagatla@st.com> Cc: robherring2@gmail.com, devicetree-discuss@lists.ozlabs.org, linuxppc-dev@lists.ozlabs.org, srinivas.kandagatla@st.com List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , From: Srinivas Kandagatla As follow-up to "dt: introduce of_get_child_by_name to get child node by name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla --- arch/powerpc/sysdev/qe_lib/qe.c | 5 +---- 1 files changed, 1 insertions(+), 4 deletions(-) diff --git a/arch/powerpc/sysdev/qe_lib/qe.c b/arch/powerpc/sysdev/qe_lib/qe.c index b043675..d094e51 100644 --- a/arch/powerpc/sysdev/qe_lib/qe.c +++ b/arch/powerpc/sysdev/qe_lib/qe.c @@ -568,10 +568,7 @@ struct qe_firmware_info *qe_get_firmware_info(void) } /* Find the 'firmware' child node */ - for_each_child_of_node(qe, fw) { - if (strcmp(fw->name, "firmware") == 0) - break; - } + fw = of_get_child_by_name(qe, "firmware"); of_node_put(qe); -- 1.7.0.4