From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from na01-bn1-obe.outbound.protection.outlook.com (mail-bn1lp0154.outbound.protection.outlook.com [207.46.163.154]) (using TLSv1 with cipher AES128-SHA (128/128 bits)) (No client certificate requested) by ozlabs.org (Postfix) with ESMTPS id 545762C0381 for ; Wed, 18 Dec 2013 13:45:54 +1100 (EST) Message-ID: <1387334740.3140.9.camel@snotra.buserror.net> Subject: Re: [v6][PATCH 2/5] powerpc/book3e: store crit/mc/dbg exception thread info From: Scott Wood To: Tiejun Chen Date: Tue, 17 Dec 2013 20:45:40 -0600 In-Reply-To: <1382520685-11609-3-git-send-email-tiejun.chen@windriver.com> References: <1382520685-11609-1-git-send-email-tiejun.chen@windriver.com> <1382520685-11609-3-git-send-email-tiejun.chen@windriver.com> Content-Type: text/plain; charset="UTF-8" MIME-Version: 1.0 Cc: linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , On Wed, 2013-10-23 at 17:31 +0800, Tiejun Chen wrote: > We need to store thread info to these exception thread info like something > we already did for PPC32. > > Signed-off-by: Tiejun Chen > --- > arch/powerpc/kernel/exceptions-64e.S | 22 +++++++++++++++++++--- > 1 file changed, 19 insertions(+), 3 deletions(-) > > diff --git a/arch/powerpc/kernel/exceptions-64e.S b/arch/powerpc/kernel/exceptions-64e.S > index 68d74b4..a55cf62 100644 > --- a/arch/powerpc/kernel/exceptions-64e.S > +++ b/arch/powerpc/kernel/exceptions-64e.S > @@ -36,6 +36,19 @@ > */ > #define SPECIAL_EXC_FRAME_SIZE INT_FRAME_SIZE > > +/* Now we only store something to exception thread info */ > +#define EXC_LEVEL_EXCEPTION_PROLOG(type) \ > + ld r14,PACAKSAVE(r13); \ > + CURRENT_THREAD_INFO(r14, r14); \ > + CURRENT_THREAD_INFO(r15, r1); \ > + ld r10,TI_FLAGS(r14); \ > + std r10,TI_FLAGS(r15); \ > + ld r10,TI_PREEMPT(r14); \ > + std r10,TI_PREEMPT(r15); \ > + ld r10,TI_TASK(r14); \ > + std r10,TI_TASK(r15); > + > + > /* Exception prolog code for all exceptions */ > #define EXCEPTION_PROLOG(n, intnum, type, addition) \ > mtspr SPRN_SPRG_##type##_SCRATCH,r13; /* get spare registers */ \ > @@ -69,19 +82,22 @@ > > #define CRIT_SET_KSTACK \ > ld r1,PACA_CRIT_STACK(r13); \ > - subi r1,r1,SPECIAL_EXC_FRAME_SIZE; > + subi r1,r1,SPECIAL_EXC_FRAME_SIZE; \ > + EXC_LEVEL_EXCEPTION_PROLOG(CRIT); > #define SPRN_CRIT_SRR0 SPRN_CSRR0 > #define SPRN_CRIT_SRR1 SPRN_CSRR1 > > #define DBG_SET_KSTACK \ > ld r1,PACA_DBG_STACK(r13); \ > - subi r1,r1,SPECIAL_EXC_FRAME_SIZE; > + subi r1,r1,SPECIAL_EXC_FRAME_SIZE; \ > + EXC_LEVEL_EXCEPTION_PROLOG(DBG); > #define SPRN_DBG_SRR0 SPRN_DSRR0 > #define SPRN_DBG_SRR1 SPRN_DSRR1 > > #define MC_SET_KSTACK \ > ld r1,PACA_MC_STACK(r13); \ > - subi r1,r1,SPECIAL_EXC_FRAME_SIZE; > + subi r1,r1,SPECIAL_EXC_FRAME_SIZE; \ > + EXC_LEVEL_EXCEPTION_PROLOG(MC); > #define SPRN_MC_SRR0 SPRN_MCSRR0 > #define SPRN_MC_SRR1 SPRN_MCSRR1 > We should rename these if they're going to do more than set up a stack. -Scott