From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Message-ID: <18328.2461.82013.777187@cargo.ozlabs.ibm.com> Date: Thu, 24 Jan 2008 14:44:29 +1100 From: Paul Mackerras To: Jon Loeliger Subject: Re: [PATCH 1/4 v4] POWERPC: Add _nmask_and_or_msr() declartion to asm-powerpc/system.h In-Reply-To: References: Cc: linuxppc-dev@ozlabs.org List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Jon Loeliger writes: > +extern void _nmask_and_or_msr(unsigned long nmask, unsigned long or_val); Hmmm, I wish someone would think of a better name for it. In fact I have tended to avoid using it, and instead done things like mtmsr((mfmsr() & ~x) | y); where necessary instead. Paul.