From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from de01egw01.freescale.net (de01egw01.freescale.net [192.88.165.102]) (using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)) (Client CN "de01egw01.freescale.net", Issuer "Thawte Premium Server CA" (verified OK)) by ozlabs.org (Postfix) with ESMTP id 0B6E3DDE25 for ; Fri, 27 Jul 2007 10:04:28 +1000 (EST) Date: Thu, 26 Jul 2007 19:04:17 -0500 From: Kim Phillips To: Vitaly Bordug Subject: Re: [PATCH 1/2] [POWERPC] Add support of platforms without PHY to gianfar driver Message-Id: <20070726190417.de30bed6.kim.phillips@freescale.com> In-Reply-To: <20070725174312.5818.61155.stgit@localhost.localdomain> References: <20070725174312.5818.61155.stgit@localhost.localdomain> Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Cc: linuxppc-dev@ozlabs.org, Jeff Garzik List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , On Wed, 25 Jul 2007 21:43:12 +0400 Vitaly Bordug wrote: > > Gianfar driver is now able to work without real phy subnode, > that is necessary to cope with fixed-link situation, when > SoC is connected to the Ethernet inteface or embedded switch > without any PHY. In this case, fixed-speed property will > describe such a situation for gianfar driver. > > The property is in form > > Signed-off-by: Vitaly Bordug > > --- > > arch/powerpc/sysdev/fsl_soc.c | 39 +++++++++++++++++++++++---------------- > drivers/net/gianfar.c | 17 ++++++++++++++--- please run this through checkpatch.pl until it passes. > + bus_id = of_get_property(np, "fixed_speed",NULL); hyphens are preferred for new properties. Plus, isn't fixed-link a better name? unless you instead want to put speed first and make duplexity an optional second, or possibly even a string. Also, can we get this new property documented in b-w-of in a separate patch? Kim