From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail.lixom.net (lixom.net [66.141.50.11]) by ozlabs.org (Postfix) with ESMTP id 9877FDDDF9 for ; Tue, 18 Dec 2007 09:50:40 +1100 (EST) Date: Mon, 17 Dec 2007 16:56:40 -0600 From: Olof Johansson To: Bartlomiej Zolnierkiewicz Subject: Re: [PATCH] Fix build break caused by "ide: remove ideprobe_init()" Message-ID: <20071217225640.GA22779@lixom.net> References: <200711182325.09262.bzolnier@gmail.com> <20071214090915.GA28681@lixom.net> <200712172153.31427.bzolnier@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii In-Reply-To: <200712172153.31427.bzolnier@gmail.com> Cc: linux-ide@vger.kernel.org, akpm@linux-foundation.org, linuxppc-dev@ozlabs.org List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , On Mon, Dec 17, 2007 at 09:53:31PM +0100, Bartlomiej Zolnierkiewicz wrote: > > Hi, > > applied but... > > > --- > > > > On Sun, Nov 18, 2007 at 11:25:09PM +0100, Bartlomiej Zolnierkiewicz wrote: > > > > > > * Rename ide_device_add() to ide_device_add_all() and make it accept > > > 'u8 idx[MAX_HWIFS]' instead of 'u8 idx[4]' as an argument. > > > > > > * Add ide_device_add() wrapper for ide_device_add_all(). > > > > > > * Convert ide_generic_init() to use ide_device_add_all(). > > > > > > * Remove no longer needed ideprobe_init(). > > > > > > There should be no functionality changes caused by this patch. > > > > This patch broke builds of powerpc holly_defconfig in -mm. It has > > CONFIG_EMBEDDED=y, CONFIG_IDE=n but includes linux/ide.h: > ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ > > ...could you also fix the root source of the problem so the similar issue > won't re-appear in the future? > > is IDE subsystem specific in the same way that > is libata specific, is the place to put subsystem independent > defines, inlines and co. > > There are some powerpc abusers of the above rule but they should at least cover > references to and IDE subsystem specific code with #ifdef/#endif > CONFIG_BLK_DEV_IDE. > > In arch/powerpc/platforms/embedded6xx/holly.c case it seems that > include is actually not needed and may be just removed? Yep, that was my original simple fix to the problem, but when I looked closer I wanted to get the include file fixed as well. Turns out I never posted the powerpc patch :), I'll do so (and audit other platforms for the same). Thanks, -Olof