From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from bhuna.collabora.co.uk (bhuna.collabora.co.uk [46.235.227.227]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by lists.ozlabs.org (Postfix) with ESMTPS id 3qR2qf4xSTzDq5s for ; Fri, 18 Mar 2016 09:20:46 +1100 (AEDT) Date: Thu, 17 Mar 2016 19:11:53 -0300 From: Gustavo Padovan To: Gustavo Padovan Cc: linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org, Benjamin Herrenschmidt , Paul Mackerras , Michael Ellerman Subject: Re: [PATCH] powerpc: rename to_user_ptr to __to_user_ptr Message-ID: <20160317221153.GB2619@joana> References: <1458245903-3937-1-git-send-email-gustavo@padovan.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii In-Reply-To: <1458245903-3937-1-git-send-email-gustavo@padovan.org> List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Hi, 2016-03-17 Gustavo Padovan : > From: Gustavo Padovan > > to_user_ptr() is a local macro defined by signal_32.c, rename it to > __to_user_ptr() as now we will have a global to_user_ptr() defined by > kernel.h that has a different meaning from this one. > > Cc: Benjamin Herrenschmidt > Cc: Paul Mackerras > Cc: Michael Ellerman > Signed-off-by: Gustavo Padovan > --- > arch/powerpc/kernel/signal_32.c | 18 +++++++++--------- > 1 file changed, 9 insertions(+), 9 deletions(-) We changed our mind about the names, so ignore this patch. Sorry for the noise. Gustavo