LinuxPPC-Dev Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Steven Rostedt <rostedt@goodmis.org>
To: Michael Ellerman <mpe@ellerman.id.au>
Cc: "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com>,
	linuxppc-dev@lists.ozlabs.org, Ingo Molnar <mingo@kernel.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	"H. Peter Anvin" <hpa@zytor.com>
Subject: Re: [PATCH v3 1/2] powerpc: split ftrace bits into a separate file
Date: Fri, 10 Mar 2017 10:45:30 -0500	[thread overview]
Message-ID: <20170310104530.357213c1@gandalf.local.home> (raw)
In-Reply-To: <871sugkogi.fsf@concordia.ellerman.id.au>

On Thu, 02 Mar 2017 20:38:53 +1100
Michael Ellerman <mpe@ellerman.id.au> wrote:

> Steven Rostedt <rostedt@goodmis.org> writes:
> 
> > On Tue, 28 Feb 2017 15:04:15 +1100
> > Michael Ellerman <mpe@ellerman.id.au> wrote:
> >
> > kernel/trace/ftrace.c more obvious.  
> >> 
> >> I don't know if it's really worth keeping the names the same across
> >> arches, especially as we already have:
> >> 
> >>   arch/arm64/kernel/entry-ftrace.S
> >>   arch/arm/kernel/entry-ftrace.S
> >>   arch/blackfin/kernel/ftrace-entry.S
> >>   arch/metag/kernel/ftrace_stub.S
> >> 
> >> But we can rename it if you feel strongly about it.  
> >
> > Hmm, perhaps "entry-ftrace.S" would be the better name. I never liked
> > the "mcount.S" name.  
> 
> Except what does the "entry" part mean?
> 
> Traditionally entry.S has been for the code that "enters" the kernel,
> ie. from userspace or elsewhere. But that's not the case with any of the
> ftrace code, it's kernel code called from the kernel. So using "entry"
> is a bit wrong IMHO.
> 
> So if we drop that we're left with ftrace.S - which seems perfect to me.

Yeah, I agree. But then there's the problem that ftrace.c and ftrace.S
will get the same ftrace.o. Maybe make it ftrace-hook.S ?

-- Steve

  parent reply	other threads:[~2017-03-10 15:45 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-02-21 19:01 [PATCH v3 0/2] powerpc: split ftrace bits into separate files Naveen N. Rao
2017-02-21 19:01 ` [PATCH v3 1/2] powerpc: split ftrace bits into a separate file Naveen N. Rao
2017-02-27 15:36   ` Steven Rostedt
2017-02-28  4:04     ` Michael Ellerman
2017-02-28 14:11       ` Steven Rostedt
2017-03-01 15:23         ` Naveen N. Rao
2017-03-02  9:38         ` Michael Ellerman
2017-03-10 15:08           ` Naveen N. Rao
2017-03-10 15:45           ` Steven Rostedt [this message]
2017-03-10 16:08             ` Naveen N. Rao
2017-03-10 16:54               ` Steven Rostedt
2017-03-15  9:05                 ` Naveen N. Rao
2017-03-15 13:11                   ` Steven Rostedt
2017-03-15 13:57                     ` Naveen N. Rao
2017-02-21 19:01 ` [PATCH v3 2/2] powerpc: ftrace_64: split further based on -mprofile-kernel Naveen N. Rao
2017-02-27 15:40   ` Steven Rostedt
2017-02-28  3:58     ` Michael Ellerman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170310104530.357213c1@gandalf.local.home \
    --to=rostedt@goodmis.org \
    --cc=hpa@zytor.com \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mingo@kernel.org \
    --cc=mpe@ellerman.id.au \
    --cc=naveen.n.rao@linux.vnet.ibm.com \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox