From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mx1.suse.de (mx2.suse.de [195.135.220.15]) (using TLSv1 with cipher ADH-CAMELLIA256-SHA (256/256 bits)) (No client certificate requested) by lists.ozlabs.org (Postfix) with ESMTPS id 3xJt1X42bjzDrRv for ; Sat, 29 Jul 2017 01:24:32 +1000 (AEST) Date: Fri, 28 Jul 2017 17:23:42 +0200 From: Borislav Petkov To: Brijesh Singh Cc: linux-kernel@vger.kernel.org, x86@kernel.org, linux-efi@vger.kernel.org, linuxppc-dev@lists.ozlabs.org, kvm@vger.kernel.org, Thomas Gleixner , Ingo Molnar , "H . Peter Anvin" , Andy Lutomirski , Tony Luck , Piotr Luc , Tom Lendacky , Fenghua Yu , Lu Baolu , Reza Arbab , David Howells , Matt Fleming , "Kirill A . Shutemov" , Laura Abbott , Ard Biesheuvel , Andrew Morton , Eric Biederman , Benjamin Herrenschmidt , Paul Mackerras , Konrad Rzeszutek Wilk , Jonathan Corbet , Dave Airlie , Kees Cook , Paolo Bonzini , Radim =?utf-8?B?S3LEjW3DocWZ?= , Arnd Bergmann , Tejun Heo , Christoph Lameter Subject: Re: [RFC Part1 PATCH v3 09/17] resource: Consolidate resource walking code Message-ID: <20170728152342.GB11564@nazgul.tnic> References: <20170724190757.11278-1-brijesh.singh@amd.com> <20170724190757.11278-10-brijesh.singh@amd.com> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 In-Reply-To: <20170724190757.11278-10-brijesh.singh@amd.com> List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , On Mon, Jul 24, 2017 at 02:07:49PM -0500, Brijesh Singh wrote: > From: Tom Lendacky > > The walk_iomem_res_desc(), walk_system_ram_res() and walk_system_ram_range() > functions each have much of the same code. Create a new function that > consolidates the common code from these functions in one place to reduce > the amount of duplicated code. > > Signed-off-by: Tom Lendacky > Signed-off-by: Brijesh Singh > --- > kernel/resource.c | 53 ++++++++++++++++++++++++++--------------------------- > 1 file changed, 26 insertions(+), 27 deletions(-) > > diff --git a/kernel/resource.c b/kernel/resource.c > index 9b5f044..7b20b3e 100644 > --- a/kernel/resource.c > +++ b/kernel/resource.c > @@ -397,9 +397,30 @@ static int find_next_iomem_res(struct resource *res, unsigned long desc, > res->start = p->start; > if (res->end > p->end) > res->end = p->end; > + res->desc = p->desc; > return 0; I must be going blind: where are we using that res->desc? > +static int __walk_iomem_res_desc(struct resource *res, unsigned long desc, > + bool first_level_children_only, Btw, that variable name is insanely long. The rest looks ok to me, thanks for the cleanup! -- Regards/Gruss, Boris. SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg) --