From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-0.6 required=3.0 tests=DKIM_INVALID,DKIM_SIGNED, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 268D0C48BD5 for ; Tue, 25 Jun 2019 19:39:57 +0000 (UTC) Received: from lists.ozlabs.org (lists.ozlabs.org [203.11.71.2]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail.kernel.org (Postfix) with ESMTPS id 461482085A for ; Tue, 25 Jun 2019 19:39:56 +0000 (UTC) Authentication-Results: mail.kernel.org; dkim=fail reason="signature verification failed" (1024-bit key) header.d=kernel.org header.i=@kernel.org header.b="ShVOA7PY" DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 461482085A Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=linux-foundation.org Authentication-Results: mail.kernel.org; spf=pass smtp.mailfrom=linuxppc-dev-bounces+linuxppc-dev=archiver.kernel.org@lists.ozlabs.org Received: from lists.ozlabs.org (lists.ozlabs.org [IPv6:2401:3900:2:1::3]) by lists.ozlabs.org (Postfix) with ESMTP id 45YGhT6nyxzDqWB for ; Wed, 26 Jun 2019 05:39:53 +1000 (AEST) Authentication-Results: lists.ozlabs.org; spf=pass (mailfrom) smtp.mailfrom=linux-foundation.org (client-ip=198.145.29.99; helo=mail.kernel.org; envelope-from=akpm@linux-foundation.org; receiver=) Authentication-Results: lists.ozlabs.org; dmarc=none (p=none dis=none) header.from=linux-foundation.org Authentication-Results: lists.ozlabs.org; dkim=pass (1024-bit key; unprotected) header.d=kernel.org header.i=@kernel.org header.b="ShVOA7PY"; dkim-atps=neutral Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by lists.ozlabs.org (Postfix) with ESMTPS id 45YGfM1QR6zDqLt for ; Wed, 26 Jun 2019 05:38:00 +1000 (AEST) Received: from akpm3.svl.corp.google.com (unknown [104.133.8.65]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail.kernel.org (Postfix) with ESMTPSA id C012D2085A; Tue, 25 Jun 2019 19:37:57 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=default; t=1561491478; bh=tJdGNjp4NLA7f2CJGKITTf6uA4kMX96bLEi69D1RpFc=; h=Date:From:To:Cc:Subject:In-Reply-To:References:From; b=ShVOA7PYXmmz24tjLGDu1PYm64KCDa4yjeLXa3l6FjdwwPWxrgsVBDxgsovdp7feN blu+puyvqldhGC0Wxv3kVwuVBCy18spQuzJMsEad+C5F0wrxmqqgxgvTR3f1e5CyBT eX6OYwNFOGaN5Cpc8zEu5AANzUORLi6PZJBbAynU= Date: Tue, 25 Jun 2019 12:37:57 -0700 From: Andrew Morton To: Christoph Hellwig Subject: Re: [PATCH 14/16] mm: move the powerpc hugepd code to mm/gup.c Message-Id: <20190625123757.ec7e886747bb5a9bc364107d@linux-foundation.org> In-Reply-To: <20190625143715.1689-15-hch@lst.de> References: <20190625143715.1689-1-hch@lst.de> <20190625143715.1689-15-hch@lst.de> X-Mailer: Sylpheed 3.7.0 (GTK+ 2.24.32; x86_64-pc-linux-gnu) Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit X-BeenThere: linuxppc-dev@lists.ozlabs.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Cc: x86@kernel.org, Rich Felker , Yoshinori Sato , linux-sh@vger.kernel.org, James Hogan , linuxppc-dev@lists.ozlabs.org, Khalid Aziz , Nicholas Piggin , linux-mips@vger.kernel.org, linux-mm@kvack.org, Paul Burton , Paul Mackerras , Andrey Konovalov , sparclinux@vger.kernel.org, Linus Torvalds , "David S. Miller" , linux-kernel@vger.kernel.org Errors-To: linuxppc-dev-bounces+linuxppc-dev=archiver.kernel.org@lists.ozlabs.org Sender: "Linuxppc-dev" On Tue, 25 Jun 2019 16:37:13 +0200 Christoph Hellwig wrote: > +static int gup_huge_pd(hugepd_t hugepd Naming nitlet: we have hugepd and we also have huge_pd. We have hugepte and we also have huge_pte. It make things a bit hard to remember and it would be nice to make it all consistent sometime. We're consistent with huge_pud and almost consistent with huge_pmd. To be fully consistent I guess we should make all of them have the underscore. Or not have it.