From: Will Deacon <will@kernel.org>
To: Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: linux-arch@vger.kernel.org, robh@kernel.org,
daniel@gimpelevich.san-francisco.ca.us,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
Paul Mackerras <paulus@samba.org>,
linuxppc-dev@lists.ozlabs.org, danielwa@cisco.com
Subject: Re: [PATCH v2 6/7] cmdline: Gives architectures opportunity to use generically defined boot cmdline manipulation
Date: Thu, 25 Mar 2021 19:32:17 +0000 [thread overview]
Message-ID: <20210325193216.GC16123@willie-the-truck> (raw)
In-Reply-To: <8db81511-3f28-4ef1-5e66-188cf7cafad1@csgroup.eu>
On Thu, Mar 25, 2021 at 12:18:38PM +0100, Christophe Leroy wrote:
>
>
> Le 03/03/2021 à 18:57, Will Deacon a écrit :
> > On Tue, Mar 02, 2021 at 05:25:22PM +0000, Christophe Leroy wrote:
> > > Most architectures have similar boot command line manipulation
> > > options. This patchs adds the definition in init/Kconfig, gated by
> > > CONFIG_HAVE_CMDLINE that the architectures can select to use them.
> > >
> > > In order to use this, a few architectures will have to change their
> > > CONFIG options:
> > > - riscv has to replace CMDLINE_FALLBACK by CMDLINE_FROM_BOOTLOADER
> > > - architectures using CONFIG_CMDLINE_OVERRIDE or
> > > CONFIG_CMDLINE_OVERWRITE have to replace them by CONFIG_CMDLINE_FORCE.
> > >
> > > Architectures also have to define CONFIG_DEFAULT_CMDLINE.
> > >
> > > Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>
> > > ---
> > > init/Kconfig | 56 ++++++++++++++++++++++++++++++++++++++++++++++++++++
> > > 1 file changed, 56 insertions(+)
> > >
> > > diff --git a/init/Kconfig b/init/Kconfig
> > > index 22946fe5ded9..a0f2ad9467df 100644
> > > --- a/init/Kconfig
> > > +++ b/init/Kconfig
> > > @@ -117,6 +117,62 @@ config INIT_ENV_ARG_LIMIT
> > > Maximum of each of the number of arguments and environment
> > > variables passed to init from the kernel command line.
> > > +config HAVE_CMDLINE
> > > + bool
> > > +
> > > +config CMDLINE_BOOL
> > > + bool "Default bootloader kernel arguments"
> > > + depends on HAVE_CMDLINE
> > > + help
> > > + On some platforms, there is currently no way for the boot loader to
> > > + pass arguments to the kernel. For these platforms, you can supply
> > > + some command-line options at build time by entering them here. In
> > > + most cases you will need to specify the root device here.
> >
> > Why is this needed as well as CMDLINE_FROM_BOOTLOADER? IIUC, the latter
> > will use CONFIG_CMDLINE if it fails to get anything from the bootloader,
> > which sounds like the same scenario.
> >
> > > +config CMDLINE
> > > + string "Initial kernel command string"
> >
> > s/Initial/Default
> >
> > which is then consistent with the rest of the text here.
> >
> > > + depends on CMDLINE_BOOL
> >
> > Ah, so this is a bit different and I don't think lines-up with the
> > CMDLINE_BOOL help text.
> >
> > > + default DEFAULT_CMDLINE
> > > + help
> > > + On some platforms, there is currently no way for the boot loader to
> > > + pass arguments to the kernel. For these platforms, you can supply
> > > + some command-line options at build time by entering them here. In
> > > + most cases you will need to specify the root device here.
> >
> > (same stale text)
> >
> > > +choice
> > > + prompt "Kernel command line type" if CMDLINE != ""
> > > + default CMDLINE_FROM_BOOTLOADER
> > > + help
> > > + Selects the way you want to use the default kernel arguments.
> >
> > How about:
> >
> > "Determines how the default kernel arguments are combined with any
> > arguments passed by the bootloader"
> >
> > > +config CMDLINE_FROM_BOOTLOADER
> > > + bool "Use bootloader kernel arguments if available"
> > > + help
> > > + Uses the command-line options passed by the boot loader. If
> > > + the boot loader doesn't provide any, the default kernel command
> > > + string provided in CMDLINE will be used.
> > > +
> > > +config CMDLINE_EXTEND
> >
> > Can we rename this to CMDLINE_APPEND, please? There is code in the tree
> > which disagrees about what CMDLINE_EXTEND means, so that will need be
> > to be updated to be consistent (e.g. the EFI stub parsing order). Having
> > the generic option with a different name means we won't accidentally end
> > up with the same inconsistent behaviours.
>
> Argh, yes. Seems like the problem is even larger than that IIUC:
>
> - For ARM it means to append the bootloader arguments to the CONFIG_CMDLINE
> - For Powerpc it means to append the CONFIG_CMDLINE to the bootloader arguments
> - For SH it means to append the CONFIG_CMDLINE to the bootloader arguments
> - For EFI it means to append the bootloader arguments to the CONFIG_CMDLINE
> - For OF it means to append the CONFIG_CMDLINE to the bootloader arguments
>
> So what happens on ARM for instance when it selects CONFIG_OF for instance ?
I think ARM gets different behaviour depending on whether it uses ATAGs or
FDT.
> Or should we consider that EXTEND means APPEND or PREPEND, no matter which ?
> Because EXTEND is for instance used for:
>
> config INITRAMFS_FORCE
> bool "Ignore the initramfs passed by the bootloader"
> depends on CMDLINE_EXTEND || CMDLINE_FORCE
Oh man, I didn't spot that one :(
I think I would make the generic options explicit: either APPEND or PREPEND.
Then architectures which choose to define CMDLINE_EXTEND in their Kconfigs
can select the generic option that matches their behaviour.
INITRAMFS_FORCE sounds like it should depend on APPEND (assuming that means
CONFIG_CMDLINE is appended to the bootloader arguments).
Will
next prev parent reply other threads:[~2021-03-25 19:32 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-03-02 17:25 [PATCH v2 0/7] Improve boot command line handling Christophe Leroy
2021-03-02 17:25 ` [PATCH v2 1/7] cmdline: Add generic function to build command line Christophe Leroy
2021-03-03 17:28 ` Will Deacon
2021-03-03 17:38 ` Christophe Leroy
2021-03-03 17:46 ` Will Deacon
2021-03-03 17:57 ` Christophe Leroy
2021-03-03 18:16 ` Will Deacon
2021-03-05 11:58 ` Michael Ellerman
2021-03-05 12:49 ` Christophe Leroy
2021-03-05 18:35 ` Segher Boessenkool
2021-03-05 18:33 ` Segher Boessenkool
2021-03-03 17:39 ` Will Deacon
2021-03-02 17:25 ` [PATCH v2 2/7] drivers: of: use cmdline building function Christophe Leroy
2021-03-02 17:25 ` [PATCH v2 3/7] powerpc: convert to generic builtin command line Christophe Leroy
2021-03-02 17:25 ` [PATCH v2 4/7] cmdline: Add capability to prepend the " Christophe Leroy
2021-03-03 18:19 ` Will Deacon
2021-03-02 17:25 ` [PATCH v2 5/7] powerpc: add capability to prepend default " Christophe Leroy
2021-03-02 17:25 ` [PATCH v2 6/7] cmdline: Gives architectures opportunity to use generically defined boot cmdline manipulation Christophe Leroy
2021-03-02 19:30 ` kernel test robot
2021-03-03 17:57 ` Will Deacon
2021-03-25 11:18 ` Christophe Leroy
2021-03-25 19:32 ` Will Deacon [this message]
2021-03-26 6:18 ` Christophe Leroy
2021-03-26 6:44 ` Christophe Leroy
2021-03-02 17:25 ` [PATCH v2 7/7] powerpc: use generic CMDLINE manipulations Christophe Leroy
2021-03-02 17:35 ` [PATCH v2 0/7] Improve boot command line handling Daniel Walker
2021-03-02 17:39 ` Christophe Leroy
2021-03-03 2:01 ` Rob Herring
2021-03-03 17:39 ` Daniel Walker
2021-03-03 18:07 ` Christophe Leroy
2021-03-03 18:53 ` Daniel Walker
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20210325193216.GC16123@willie-the-truck \
--to=will@kernel.org \
--cc=christophe.leroy@csgroup.eu \
--cc=daniel@gimpelevich.san-francisco.ca.us \
--cc=danielwa@cisco.com \
--cc=devicetree@vger.kernel.org \
--cc=linux-arch@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linuxppc-dev@lists.ozlabs.org \
--cc=paulus@samba.org \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox