From: Alexandru Elisei <alexandru.elisei@arm.com>
To: kvm@vger.kernel.org, andrew.jones@linux.dev, lvivier@redhat.com,
thuth@redhat.com, frankja@linux.ibm.com, imbrenda@linux.ibm.com,
nrb@linux.ibm.com, pbonzini@redhat.com, alexandru.elisei@arm.com,
eric.auger@redhat.com, kvmarm@lists.linux.dev,
linuxppc-dev@lists.ozlabs.org, kvm-riscv@lists.infradead.org,
david@redhat.com, linux-s390@vger.kernel.org
Subject: [kvm-unit-tests PATCH 0/2] scripts: extra_params rework
Date: Wed, 25 Jun 2025 16:43:52 +0100 [thread overview]
Message-ID: <20250625154354.27015-1-alexandru.elisei@arm.com> (raw)
This series was split from the series that adds support to use kvmtool when
using the scripts to run the tests [1]. kvmtool will be supported only for arm
and arm64, as they are the only architectures that compile the tests to run with
kvmtool.
The justification for these changes is to be able to introduce
kvmtool_params for kvmtool specific command line options, and to make a
clear distinction between the qemu options and the kvmtool options. This is
why qemu_params was added as a replacement for extra_params. extra_params
was kept for compatibility purposes for user's custom test definitions.
To avoid duplication of the arguments that are passed to a test's main()
function, test_args has been split from qemu_params. The same test_args
will be used by both qemu and kvmtool.
[1] https://lore.kernel.org/kvm/20250507151256.167769-1-alexandru.elisei@arm.com/
Alexandru Elisei (2):
scripts: unittests.cfg: Rename 'extra_params' to 'qemu_params'
scripts: Add 'test_args' test definition parameter
arm/unittests.cfg | 94 ++++++++++++++----------
docs/unittests.txt | 30 +++++---
powerpc/unittests.cfg | 21 +++---
riscv/unittests.cfg | 2 +-
s390x/unittests.cfg | 53 +++++++-------
scripts/common.bash | 16 +++--
scripts/runtime.bash | 24 ++++---
x86/unittests.cfg | 164 ++++++++++++++++++++++++------------------
8 files changed, 237 insertions(+), 167 deletions(-)
base-commit: 507612326c9417b6330b91f7931678a4c6866395
--
2.50.0
next reply other threads:[~2025-06-25 15:44 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-25 15:43 Alexandru Elisei [this message]
2025-06-25 15:43 ` [kvm-unit-tests PATCH 1/2] scripts: unittests.cfg: Rename 'extra_params' to 'qemu_params' Alexandru Elisei
2025-07-02 14:07 ` Thomas Huth
2025-06-25 15:43 ` [kvm-unit-tests PATCH 2/2] scripts: Add 'test_args' test definition parameter Alexandru Elisei
2025-07-02 14:09 ` Thomas Huth
2025-06-26 14:58 ` [kvm-unit-tests PATCH 0/2] scripts: extra_params rework Andrew Jones
2025-07-02 13:23 ` Andrew Jones
2025-07-04 8:41 ` Andrew Jones
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250625154354.27015-1-alexandru.elisei@arm.com \
--to=alexandru.elisei@arm.com \
--cc=andrew.jones@linux.dev \
--cc=david@redhat.com \
--cc=eric.auger@redhat.com \
--cc=frankja@linux.ibm.com \
--cc=imbrenda@linux.ibm.com \
--cc=kvm-riscv@lists.infradead.org \
--cc=kvm@vger.kernel.org \
--cc=kvmarm@lists.linux.dev \
--cc=linux-s390@vger.kernel.org \
--cc=linuxppc-dev@lists.ozlabs.org \
--cc=lvivier@redhat.com \
--cc=nrb@linux.ibm.com \
--cc=pbonzini@redhat.com \
--cc=thuth@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox