From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from ozlabs.org (ozlabs.org [IPv6:2401:3900:2:1::2]) (using TLSv1.2 with cipher ADH-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by lists.ozlabs.org (Postfix) with ESMTPS id 3vYnM74NxJzDqGv for ; Thu, 2 Mar 2017 20:38:59 +1100 (AEDT) From: Michael Ellerman To: Steven Rostedt Cc: "Naveen N. Rao" , linuxppc-dev@lists.ozlabs.org, Ingo Molnar , Thomas Gleixner , "H. Peter Anvin" Subject: Re: [PATCH v3 1/2] powerpc: split ftrace bits into a separate file In-Reply-To: <20170228091147.69b836a8@gandalf.local.home> References: <20170227103650.0955c5eb@gandalf.local.home> <87wpcbota8.fsf@concordia.ellerman.id.au> <20170228091147.69b836a8@gandalf.local.home> Date: Thu, 02 Mar 2017 20:38:53 +1100 Message-ID: <871sugkogi.fsf@concordia.ellerman.id.au> MIME-Version: 1.0 Content-Type: text/plain List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Steven Rostedt writes: > On Tue, 28 Feb 2017 15:04:15 +1100 > Michael Ellerman wrote: > > kernel/trace/ftrace.c more obvious. >> >> I don't know if it's really worth keeping the names the same across >> arches, especially as we already have: >> >> arch/arm64/kernel/entry-ftrace.S >> arch/arm/kernel/entry-ftrace.S >> arch/blackfin/kernel/ftrace-entry.S >> arch/metag/kernel/ftrace_stub.S >> >> But we can rename it if you feel strongly about it. > > Hmm, perhaps "entry-ftrace.S" would be the better name. I never liked > the "mcount.S" name. Except what does the "entry" part mean? Traditionally entry.S has been for the code that "enters" the kernel, ie. from userspace or elsewhere. But that's not the case with any of the ftrace code, it's kernel code called from the kernel. So using "entry" is a bit wrong IMHO. So if we drop that we're left with ftrace.S - which seems perfect to me. cheers