From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from lists.ozlabs.org (lists.ozlabs.org [112.213.38.117]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.lore.kernel.org (Postfix) with ESMTPS id 7CCC6C27C52 for ; Tue, 4 Jun 2024 18:00:58 +0000 (UTC) Authentication-Results: lists.ozlabs.org; dkim=fail reason="signature verification failed" (2048-bit key; unprotected) header.d=intel.com header.i=@intel.com header.a=rsa-sha256 header.s=Intel header.b=S9MyuWI7; dkim-atps=neutral Received: from boromir.ozlabs.org (localhost [IPv6:::1]) by lists.ozlabs.org (Postfix) with ESMTP id 4Vtz0m3fNlz3cYr for ; Wed, 5 Jun 2024 04:00:56 +1000 (AEST) Authentication-Results: lists.ozlabs.org; dmarc=pass (p=none dis=none) header.from=linux.intel.com Authentication-Results: lists.ozlabs.org; dkim=pass (2048-bit key; unprotected) header.d=intel.com header.i=@intel.com header.a=rsa-sha256 header.s=Intel header.b=S9MyuWI7; dkim-atps=neutral Authentication-Results: lists.ozlabs.org; spf=pass (sender SPF authorized) smtp.mailfrom=intel.com (client-ip=192.198.163.10; helo=mgamail.intel.com; envelope-from=jani.nikula@intel.com; receiver=lists.ozlabs.org) X-Greylist: delayed 64 seconds by postgrey-1.37 at boromir; Tue, 04 Jun 2024 17:47:40 AEST Received: from mgamail.intel.com (mgamail.intel.com [192.198.163.10]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by lists.ozlabs.org (Postfix) with ESMTPS id 4VtjP8251Zz3c9r for ; Tue, 4 Jun 2024 17:47:39 +1000 (AEST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=intel.com; i=@intel.com; q=dns/txt; s=Intel; t=1717487261; x=1749023261; h=from:to:cc:subject:in-reply-to:references:date: message-id:mime-version; bh=72AZit+fGSAltF/zxrshQ3AcOBabtAGvP903E1S/6ZE=; b=S9MyuWI7GIBzOP/G6Pfm57r99tMsP843YbemF/GkDinbrCpVUJ/8tC3s 1Sp7cQi5sWtOvtYBwSqTbzlCPLpmyb+8RSe6iqyRDUJzqtW/hHtiAKwZd aH6346SJWAg5l/M9Gq+5LLDlYDmRN05doIDf8/InFJWC0OcW3IJB655zy rJTuHscypIoHxZcmKLwDiAXm32MD3awcHYQEPWTu07c9xTPaUTJZ+VGxW w5NwVAfaLOkHZOFenGlVbtG3eKTZo6wHH9kmZy767KiXx7HOollsjpUMe Y10N7sz1tJ6OFrp1ZZ2YGfpFIrC5r3q/X1GDZTBhLTU+s0zQaorvjo//0 Q==; X-CSE-ConnectionGUID: kqxy86PrS4+YE7AQCZXICA== X-CSE-MsgGUID: pE7xG5jNSYOTvEyB/E6T+Q== X-IronPort-AV: E=McAfee;i="6600,9927,11092"; a="25412070" X-IronPort-AV: E=Sophos;i="6.08,213,1712646000"; d="scan'208";a="25412070" Received: from fmviesa009.fm.intel.com ([10.60.135.149]) by fmvoesa104.fm.intel.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 04 Jun 2024 00:46:30 -0700 X-CSE-ConnectionGUID: L1vS2iCsS0qNl7Ekvd+3Hw== X-CSE-MsgGUID: FcxQSXvDT6KeINvTUaFx8g== X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="6.08,213,1712646000"; d="scan'208";a="37269403" Received: from mwiniars-desk2.ger.corp.intel.com (HELO localhost) ([10.245.246.102]) by fmviesa009-auth.fm.intel.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 04 Jun 2024 00:45:40 -0700 From: Jani Nikula To: Andy Shevchenko , Andy Shevchenko , "Rafael J. Wysocki" , Greg Kroah-Hartman , Corey Minyard , Allen Pais , Sebastian Reichel , Perry Yuan , Giovanni Cabiddu , Herbert Xu , Nuno Sa , Guenter Roeck , Randy Dunlap , Andi Shyti , Heiner Kallweit , Lee Jones , Samuel Holland , Elad Nachman , Arseniy Krasnov , Johannes Berg , Gregory Greenman , Benjamin Berg , Bjorn Helgaas , Robert Richter , Vinod Koul , Chunfeng Yun , Linus Walleij , Hans de Goede , Ilpo =?utf-8?Q?J=C3=A4rvinen?= , Nikita Kravets , Jiri Slaby , Srinivas Pandruvada , Stanley Chang , Heikki Krogerus , Abdel Alkuor , Kent Overstreet , Eric Biggers , Kees Cook , Ingo Molnar , "Steven Rostedt (Google)" , Daniel Bristot de Oliveira , Andrew Morton , Hugh Dickins , Abel Wu , John Johansen , Mimi Zohar , Stefan Berger , Roberto Sassu , Eric Snowberg , Takashi Iwai , Takashi Sakamoto , Jiapeng Chong , Mark Brown , Kuninori Morimoto , linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org, keyrings@vger.kernel.org, linux-crypto@vger.kernel.org, linux-acpi@vger.kernel.org, linux-ide@vger.kernel.org, openipmi-developer@lists.sourceforge.net, linux-clk@vger.kernel.org, linux-rpi-kernel@lists.infradead.org, linux-arm-kernel@lists.infradead.org, linux-rockchip@lists.infradead.org, linux-tegra@vger.kernel.org, linux-pm@vger.kernel.org, qat-linux@intel.com, dri-devel@lists.freedesktop.org, intel-gfx@lists.freedesktop.org, intel-xe@lists.freedesktop.org, nouveau@lists.freedesktop.org, linux-hwmon@vger.kernel.org, linux-i2c@vger.kernel.org, linux-leds@vger.kernel.org, linux-sunxi@lists.linux.dev, linux-omap@vger.kernel.org, linux-mmc@vger.kernel.org, linux-mtd@lists.infradead.org, netdev@vger.kernel.org, linux-wireless@vger.kernel.org, linux-pci@vger.kernel.org, linux-mediatek@lists.infradead.org, linux-phy@lists.infradead.org, linux-gpio@vger.kernel.org, platform-driver-x86@vger.kernel.org, linux-staging@lists.linux.dev, linux-usb@vger.kernel.org, linux-fbdev@vger.kernel.org, linux-bcachefs@vger.kernel.org, linux-hardening@vger.kernel.org, cgroups@vger.kernel.org, linux-trace-kernel@vger.kernel.org, linux-mm@kvack.org, apparmor@lists.ubuntu.com, linux-security-module@vger.kernel.org, linux-integrity@vger.kernel.org, alsa-devel@alsa-project.org, linux-sound@vger.kernel.org Subject: Re: [PATCH v1 1/1] treewide: Align match_string() with sysfs_match_string() In-Reply-To: <20240603211538.289765-1-andriy.shevchenko@linux.intel.com> Organization: Intel Finland Oy - BIC 0357606-4 - Westendinkatu 7, 02160 Espoo References: <20240603211538.289765-1-andriy.shevchenko@linux.intel.com> Date: Tue, 04 Jun 2024 10:45:37 +0300 Message-ID: <87tti9cfry.fsf@intel.com> MIME-Version: 1.0 Content-Type: text/plain X-Mailman-Approved-At: Wed, 05 Jun 2024 03:59:09 +1000 X-BeenThere: linuxppc-dev@lists.ozlabs.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Cc: Juri Lelli , Andrew Lunn , Prashant Gaikwad , Heiko Stuebner , "Rafael J. Wysocki" , Viresh Kumar , Jaroslav Kysela , Ben Segall , Pavel Machek , Miquel Raynal , Kishon Vijay Abraham I , Vincent Guittot , James Morris , Tvrtko Ursulin , Danilo Krummrich , Mel Gorman , Jean Delvare , Potnuri Bharat Teja , Nicholas Piggin , Thomas Gleixner , Zhihao Cheng , Dietmar Eggemann , Scott Branden , Dmitry Kasatkin , Mahesh J Salgaonkar , Masami Hiramatsu , " Gautham R. Shenoy" , Tejun Heo , Linus Torvalds , Lukasz Luba , Zefan Li , Dave Hansen , Clemens Ladisch , Liam Girdwood , Hu Ziji , Eric Dumazet , Thierry Reding , Oliver O'Halloran , Mario Limonciello , Valentin Schneider , Paul Moore , Gregory Clement , Daniel Lezcano , Jonathan Hunter , Len Brown , Brian Foster , Maxime Ripard , Jason Baron , Stephen Boyd , Daniel Bristot de Oliveira , Miri Korenblit , Ulf Hansson , Karol Herbst , Alexander Shishkin , Michael Turquette , Joonas Lahtinen , Jernej Skrabec , Peter Zijlstra , Chen-Yu Tsai , Broadcom internal kernel review list , "Naveen N. Rao" , Paolo Abeni , "Serge E. Hallyn" , Lyude Paul , Ray Jui , Damien Le Moal , Borislav Petkov , Rodrigo Vivi , Sergey Shtylyov , Thinh Nguyen , Sebastian Reichel , Daniel Scally , JC Kuo , Sakari Ailus , "David S. Miller" , Vignesh Raghavendra , Tony Lindgre n , Takashi Iwai , David Howells , Niklas Cassel , Huang Rui , "H. Peter Anvin" , David Airlie , Jim Cromie , Florian Fainelli , Richard Weinberger , x86@kernel.org, Ingo Molnar , Jakub Kicinski , Zhang Rui , Sebastian Hesselbarth , Thomas Zimmermann , Kalle Valo , Maarten Lankhorst , Matthias Brugger , AngeloGioacchino Del Regno , Peter De Schrijver , Adrian Hunter , Daniel Vetter , Johannes Weiner , Mathieu Desnoyers , Helge Deller Errors-To: linuxppc-dev-bounces+linuxppc-dev=archiver.kernel.org@lists.ozlabs.org Sender: "Linuxppc-dev" On Sun, 02 Jun 2024, Andy Shevchenko wrote: > Make two APIs look similar. Hence convert match_string() to be > a 2-argument macro. In order to avoid unneeded churn, convert > all users as well. There is no functional change intended. Why do we think it's a good idea to increase and normalize the use of double-underscore function names across the kernel, like __match_string() in this case? It should mean "reserved for the implementation, not to be called directly". If it's to be used directly, it should be named accordingly, right? Being in line with __sysfs_match_string() isn't a great argument alone, because this adds three times the number of __match_string() calls than there are __sysfs_match_string() calls. It's not a good model to follow. Arguably both should be renamed. BR, Jani. -- Jani Nikula, Intel