From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mx0a-001b2d01.pphosted.com (mx0b-001b2d01.pphosted.com [148.163.158.5]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by lists.ozlabs.org (Postfix) with ESMTPS id 3zLwVl47GKzF0cP for ; Wed, 17 Jan 2018 16:23:58 +1100 (AEDT) Received: from pps.filterd (m0098414.ppops.net [127.0.0.1]) by mx0b-001b2d01.pphosted.com (8.16.0.22/8.16.0.22) with SMTP id w0H5NsqU064806 for ; Wed, 17 Jan 2018 00:23:56 -0500 Received: from e06smtp15.uk.ibm.com (e06smtp15.uk.ibm.com [195.75.94.111]) by mx0b-001b2d01.pphosted.com with ESMTP id 2fhs4g76pu-1 (version=TLSv1.2 cipher=AES256-SHA bits=256 verify=NOT) for ; Wed, 17 Jan 2018 00:23:56 -0500 Received: from localhost by e06smtp15.uk.ibm.com with IBM ESMTP SMTP Gateway: Authorized Use Only! Violators will be prosecuted for from ; Wed, 17 Jan 2018 05:23:48 -0000 From: "Aneesh Kumar K.V" To: Christophe LEROY , Benjamin Herrenschmidt , Paul Mackerras , Michael Ellerman , Scott Wood , Nicholas Piggin Cc: linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH 1/3] powerpc/32: Fix hugepage allocation on 8xx at hint address In-Reply-To: <7341aef1-f2ac-6e9b-8279-93b0f0649b81@c-s.fr> References: <9a5dadc10f88e2fc0ac9fb5d18c5424df33f3f4c.1515169256.git.christophe.leroy@c-s.fr> <876081by7g.fsf@linux.vnet.ibm.com> <945affcd-b25c-bc6e-68e5-8bbbcd31c0fd@linux.vnet.ibm.com> <7341aef1-f2ac-6e9b-8279-93b0f0649b81@c-s.fr> Date: Wed, 17 Jan 2018 10:53:41 +0530 MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Message-Id: <87y3kxrrc2.fsf@linux.vnet.ibm.com> List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Christophe LEROY writes: >> >>> How should I split in separate patches ? Something like ? >>> 1/ Slice support for PPC32 > 2/ Activate slice for 8xx >>=20 >> Yes something like that. Will you=C2=A0 be able to avoid that >> =C2=A0if (SLICE_NUM_HIGH) from the code? That makes the code ugly. Righ= t now=20 >> i don't have definite suggestion on what we could do though. >>=20 > > Could use #ifdefs instead, but in my mind it would be even more ugly. > > I would have liked just doing nothing, but the issue is that at the=20 > moment bitmap_xxx() functions are not prepared to handle bitmaps of size= =20 > zero. Should we try to change that ? Any chance to succeed ? > How much code duplication it is to do slice_32.c? Michael, What do you suggest here? -aneesh