LinuxPPC-Dev Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Kumar Gala <galak@kernel.crashing.org>
To: Paul Mackerras <paulus@samba.org>
Cc: ppc-dev list <linuxppc-dev@ozlabs.org>
Subject: Status of patches (ppc32 mm init clean and 85xx kernel reloc)
Date: Tue, 8 Apr 2008 09:06:08 -0500	[thread overview]
Message-ID: <88C63CCF-7ED6-486F-8E95-FABD6CEE92E0@kernel.crashing.org> (raw)

Paul,

Here's my take on the current status of the patchset:

[POWERPC] bootwrapper: Allow specifying of image physical offset

reworked to look at PHDR (needs linker script update patch).  Still  
open question on how best to do that (objdump, readelf, C program,  
suggestions)

[POWERPC] Remove Kconfig option BOOT_LOAD

should be acceptable.

[POWERPC] Provide access to arch/powerpc include path on ppc64

should be acceptable (desired by others).

[POWERPC] Remove and replace uses of PPC_MEMSTART with memstart_addr

You had some questions about _stext and the PAGE_OFFSET vs  
KERNELBASE.  Not sure if you are satisfied with the answers.

[POWERPC] Introduce lowmem_end_addr to distiguish from total_lowmem

No comments.  Should be straight forward.

[POWERPC] 85xx: Cleanup TLB initialization

Only effects 85xx and I don't have issues with it :)

[POWERPC] Use lowmem_end_addr to limit lmb allocations on ppc32

No comments.  Straight forward patch.

[POWERPC] Rename __initial_memory_limit to __initial_memory_limit_addr

No comments.  Straight forward patch.

[POWERPC] Clean up some linker and symbol usage

No comments.  Straight forward patch.

[POWERPC] Move phys_addr_t definition into asm/types.h

I had an open question if the Kconfig for PHYS_64BIT should get set on  
PPC64 as well (has not effect).

I reworked the asm/types.h bits to look like:
+#if defined(CONFIG_PPC64) || defined(CONFIG_PHYS_64BIT)
+typedef __u64 phys_addr_t;
+#else
+typedef __u32 phys_addr_t;
+#endif

[POWERPC] 85xx: Add support for relocatble kernel (and booting at non- 
zero

Should probably get a bit more review.

[POWERPC] Update linker script to properly set physical addresses

You felt LOAD_OFFSET should be (CONFIG_PAGE_OFFSET -  
CONFIG_PHYSICAL_START).  I disagreed.  We need to resolve.

I think we should be able to quickly resolve and get into powerpc-next  
all but the '85xx: Add support for relocatable kernel' and  
'bootwrapper: Allow specifying of image..' patches.  If we can close  
on the phys_addr_t and linker script patches that would be great.

thanks

- k

             reply	other threads:[~2008-04-08 14:06 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-04-08 14:06 Kumar Gala [this message]
2008-04-10  2:57 ` Status of patches (ppc32 mm init clean and 85xx kernel reloc) Paul Mackerras
2008-04-10 10:11   ` Kumar Gala

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=88C63CCF-7ED6-486F-8E95-FABD6CEE92E0@kernel.crashing.org \
    --to=galak@kernel.crashing.org \
    --cc=linuxppc-dev@ozlabs.org \
    --cc=paulus@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox