From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from gate.crashing.org (gate.crashing.org [63.228.1.57]) (using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)) (Client did not present a certificate) by ozlabs.org (Postfix) with ESMTP id B80D7DDF2E for ; Thu, 24 Jan 2008 03:13:50 +1100 (EST) Message-Id: From: Kumar Gala To: Jochen Friedrich In-Reply-To: <4797641F.4000902@scram.de> Content-Type: text/plain; charset=US-ASCII; format=flowed; delsp=yes Mime-Version: 1.0 (Apple Message framework v915) Subject: Re: [PATCHv2 0/8] [POWERPC] 8xx cleanups Date: Wed, 23 Jan 2008 10:11:01 -0600 References: <4797641F.4000902@scram.de> Cc: Scott Wood , "Kernel, Linux" , linuxppc-dev list List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , On Jan 23, 2008, at 9:58 AM, Jochen Friedrich wrote: > Hi, > > this is a series against paulus for-2.6.25 tree to clean up various > 8xx related stuff. > The series can be pulled from git://git.bocc.de/dbox2.git cleanup. > Patch 6 has been modified to remove the #ifdefs as suggested by > Arndt Bergmann. > Patch 8 is a new one. > > [POWERPC] Remove unused m8xx_cpm_hostalloc/free/dump() > [POWERPC] Rename m8xx_pic_init to mpc8xx_pics_init > [POWERPC] Remove unneeded and misspelled prototype m8xx_calibrate_decr > [POWERPC] Remove declaration of m8xx_pic_init. > [POWERPC] Remove sysdev/commproc.h > [POWERPC] Get rid of conditional includes of board specific setup > [POWERPC] Rename commproc to cpm1 and cpm2_common.c to cpm2.c > [POWERPC] Move definition of buffer descriptor to cpm.h These roughly look good, had a few comments. Don't see any reason why they can't go in. What impact do the have on boards in arch/ppc being able to build? - k