From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from omx2.sgi.com (omx2-ext.sgi.com [192.48.171.19]) by ozlabs.org (Postfix) with ESMTP id 2B33367B83 for ; Fri, 20 Oct 2006 08:31:22 +1000 (EST) Date: Thu, 19 Oct 2006 15:31:13 -0700 (PDT) From: Christoph Lameter To: Paul Mackerras Subject: Re: kernel BUG in __cache_alloc_node at linux-2.6.git/mm/slab.c:3177! In-Reply-To: <17719.64246.555371.701194@cargo.ozlabs.ibm.com> Message-ID: References: <1161026409.31903.15.camel@farscape> <1161031821.31903.28.camel@farscape> <17717.50596.248553.816155@cargo.ozlabs.ibm.com> <17718.39522.456361.987639@cargo.ozlabs.ibm.com> <17719.1849.245776.4501@cargo.ozlabs.ibm.com> <20061019163044.GB5819@krispykreme> <17719.64246.555371.701194@cargo.ozlabs.ibm.com> MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: Christoph Lameter Cc: akpm@osdl.org, linuxppc-dev@ozlabs.org, Anton Blanchard , linux-kernel@vger.kernel.org List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , On Fri, 20 Oct 2006, Paul Mackerras wrote: > What exactly does "available" mean in this context? The console log I > posted earlier showed node 0 as having an active PFN range of 32768 - > 278528 (245760 pages, or 960MB), and then showed a "freeing bootmem > node 0" message, *before* we hit the BUG. Available in the sense that the page allocator can allocate from them. Will's console output shows that all memory of node 0 is allocated and not available. > If "available" doesn't mean "there are active pages which have been > given to the VM system via free_all_bootmem_node()", what does it > mean? The page allocator must be running and able to serve pages from the boot node. This fails for some reason and the slab cannot bootstrap. The memory not available is the first guess. Could you trace the allocation in the page allocator (__alloc_pages) when the slab attempts to bootstrap and figure out why exactly the allocation fails?