From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from lists.ozlabs.org (lists.ozlabs.org [112.213.38.117]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.lore.kernel.org (Postfix) with ESMTPS id 526CCC54798 for ; Thu, 7 Mar 2024 19:54:09 +0000 (UTC) Authentication-Results: lists.ozlabs.org; dkim=fail reason="signature verification failed" (2048-bit key; unprotected) header.d=kernel.org header.i=@kernel.org header.a=rsa-sha256 header.s=k20201202 header.b=bp/jepb4; dkim-atps=neutral Received: from boromir.ozlabs.org (localhost [IPv6:::1]) by lists.ozlabs.org (Postfix) with ESMTP id 4TrKkR6w99z3vYF for ; Fri, 8 Mar 2024 06:54:07 +1100 (AEDT) Authentication-Results: lists.ozlabs.org; dkim=pass (2048-bit key; unprotected) header.d=kernel.org header.i=@kernel.org header.a=rsa-sha256 header.s=k20201202 header.b=bp/jepb4; dkim-atps=neutral Authentication-Results: lists.ozlabs.org; spf=pass (sender SPF authorized) smtp.mailfrom=kernel.org (client-ip=2604:1380:4641:c500::1; helo=dfw.source.kernel.org; envelope-from=cassel@kernel.org; receiver=lists.ozlabs.org) Received: from dfw.source.kernel.org (dfw.source.kernel.org [IPv6:2604:1380:4641:c500::1]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)) (No client certificate requested) by lists.ozlabs.org (Postfix) with ESMTPS id 4TrKjG2bfzz3blb for ; Fri, 8 Mar 2024 06:53:06 +1100 (AEDT) Received: from smtp.kernel.org (transwarp.subspace.kernel.org [100.75.92.58]) by dfw.source.kernel.org (Postfix) with ESMTP id 7217C61CD3; Thu, 7 Mar 2024 19:53:04 +0000 (UTC) Received: by smtp.kernel.org (Postfix) with ESMTPSA id 6C4ECC433C7; Thu, 7 Mar 2024 19:52:56 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1709841184; bh=zBtZ5IOpkL6qCfo2I5F6M8ftp0zLjynvpva1eSiBuSI=; h=Date:From:To:Cc:Subject:References:In-Reply-To:From; b=bp/jepb4PDvsNrjk56N3ijuTUlescXOvoEL1HEYCfWnGtSJ5C2lciuKIk9hA3sNLN bauPP3oAanTRILudB5QaMYsIwhDnQeJgMVYm1WQbwu2/T5yDhsjpnulrhAzJSyM0Um JSMNL1vDNLWZdY0h9jv3RuugiiMLH4eRc3RAY9fkP3uivAoUWyMJvQmEjckoo2KjtU 9KqWTy+EFjPHoe8Cvm1gfS4PHZmArqpr84IwIWhs5aFsxn22g3DjPefBB8NHLkt1XW JZgtpaxHi5t367t6OiIreMnBe+pN+axheeVGhig2M9HfvhCTf3kvKSM1WGUAgl46qs N5f5iB1+2AGww== Date: Thu, 7 Mar 2024 20:52:53 +0100 From: Niklas Cassel To: Manivannan Sadhasivam Subject: Re: [PATCH v9 02/10] PCI: dwc: ep: Rename dw_pcie_ep_exit() to dw_pcie_ep_deinit() Message-ID: References: <20240304-pci-dbi-rework-v9-0-29d433d99cda@linaro.org> <20240304-pci-dbi-rework-v9-2-29d433d99cda@linaro.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20240304-pci-dbi-rework-v9-2-29d433d99cda@linaro.org> X-BeenThere: linuxppc-dev@lists.ozlabs.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Cc: Krzysztof =?utf-8?Q?Wilczy=C5=84ski?= , Vignesh Raghavendra , Kunihiko Hayashi , linux-pci@vger.kernel.org, Lorenzo Pieralisi , Frank Li , Minghuan Lian , Thierry Reding , Kishon Vijay Abraham I , Fabio Estevam , Marek Vasut , Kishon Vijay Abraham I , Rob Herring , Jesper Nilsson , linux-tegra@vger.kernel.org, linux-arm-kernel@axis.com, Jonathan Hunter , NXP Linux Team , Richard Zhu , Srikanth Thokala , linux-arm-msm@vger.kernel.org, Sascha Hauer , linuxppc-dev@lists.ozlabs.org, Bjorn Helgaas , linux-omap@vger.kernel.org, Mingkai Hu , linux-arm-kernel@ lists.infradead.org, Roy Zang , Jingoo Han , Yoshihiro Shimoda , linux-kernel@vger.kernel.org, Vidya Sagar , linux-renesas-soc@vger.kernel.org, Masami Hiramatsu , Pengutronix Kernel Team , Gustavo Pimentel , Shawn Guo , Lucas Stach Errors-To: linuxppc-dev-bounces+linuxppc-dev=archiver.kernel.org@lists.ozlabs.org Sender: "Linuxppc-dev" On Mon, Mar 04, 2024 at 02:52:14PM +0530, Manivannan Sadhasivam wrote: > dw_pcie_ep_exit() API is undoing what the dw_pcie_ep_init() API has done > already (at least partly). But the API name dw_pcie_ep_exit() is not quite > reflecting that. So let's rename it to dw_pcie_ep_deinit() to make the > purpose of this API clear. This also aligns with the DWC host driver. > > Reviewed-by: Frank Li > Signed-off-by: Manivannan Sadhasivam > --- Reviewed-by: Niklas Cassel