From: Finn Thain <fthain@telegraphics.com.au>
To: Geert Uytterhoeven <geert@linux-m68k.org>
Cc: linux-kernel <linux-kernel@vger.kernel.org>,
Linux/m68k <linux-m68k@vger.kernel.org>,
linuxppc-dev <linuxppc-dev@lists.ozlabs.org>
Subject: Re: [RFC v3 24/24] m68k: Dispatch nvram_ops calls to Atari or Mac functions
Date: Thu, 2 Jul 2015 12:07:14 +1000 (AEST) [thread overview]
Message-ID: <alpine.LNX.2.00.1507021146530.15903@nippy.intranet> (raw)
In-Reply-To: <CAMuHMdX0c3BjhkSMv4fUe1WVWDHhqRMHz=K15750EBatwkJisQ@mail.gmail.com>
On Mon, 29 Jun 2015, Geert Uytterhoeven wrote:
> On Sun, Jun 28, 2015 at 3:42 AM, Finn Thain <fthain@telegraphics.com.au>
> wrote:
> > --- linux.orig/arch/m68k/kernel/setup_mm.c 2015-06-28 11:41:27.000000000 +1000
> > +++ linux/arch/m68k/kernel/setup_mm.c 2015-06-28 11:41:56.000000000 +1000
>
> > @@ -568,3 +569,109 @@ static int __init adb_probe_sync_enable
> >
> > __setup("adb_sync", adb_probe_sync_enable);
> > #endif /* CONFIG_ADB */
> > +
> > +#if IS_ENABLED(CONFIG_NVRAM)
> > +extern unsigned char mac_pram_read_byte(int);
> > +extern void mac_pram_write_byte(unsigned char, int);
> > +extern ssize_t mac_pram_get_size(void);
> > +
> > +extern ssize_t atari_nvram_read(char *, size_t, loff_t *);
> > +extern ssize_t atari_nvram_write(char *, size_t, loff_t *);
> > +extern long atari_nvram_set_checksum(void);
> > +extern long atari_nvram_initialize(void);
> > +extern ssize_t atari_nvram_get_size(void);
>
> Forward declarations belong in a header file, to be included by both
> producers and consumers.
Right, will fix. (That was how the v1 patch did this. Looks like I messed
it up.)
>
> > --- linux.orig/arch/m68k/Kconfig 2015-06-28 11:41:39.000000000 +1000
> > +++ linux/arch/m68k/Kconfig 2015-06-28 11:41:56.000000000 +1000
> > @@ -72,7 +72,7 @@ config PGTABLE_LEVELS
> > default 3
> >
> > config HAVE_ARCH_NVRAM_OPS
> > - def_bool ATARI
> > + def_bool ATARI || MAC
>
> For maintainability, it's better to just have "bool" here, and let both
> the ATARI and MAC config symbols select HAVE_ARCH_NVRAM_OPS.
OK, will fix.
Thanks for your review.
--
>
> Gr{oetje,eeting}s,
>
> Geert
>
prev parent reply other threads:[~2015-07-02 2:07 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-06-28 1:41 [RFC v3 00/24] Re-use nvram module Finn Thain
2015-06-28 1:42 ` [RFC v3 01/24] scsi/atari_scsi: Dont select CONFIG_NVRAM Finn Thain
2015-06-28 1:42 ` [RFC v3 02/24] m68k/atari: Move Atari-specific code out of drivers/char/nvram.c Finn Thain
2015-06-29 7:26 ` Geert Uytterhoeven
2015-07-02 2:00 ` Finn Thain
2015-06-28 1:42 ` [RFC v3 03/24] m68k/atari: Replace nvram_{read, write}_byte with arch_nvram_ops Finn Thain
2015-06-28 1:42 ` [RFC v3 04/24] char/nvram: Re-order functions to remove forward declarations and #ifdefs Finn Thain
2015-06-28 1:42 ` [RFC v3 05/24] char/nvram: Adopt arch_nvram_ops Finn Thain
2015-06-28 1:42 ` [RFC v3 06/24] x86/thinkpad_acpi: Use arch_nvram_ops methods instead of nvram_read_byte() and nvram_write_byte() Finn Thain
2015-06-28 1:42 ` [RFC v3 07/24] char/nvram: Allow the set_checksum and initialize ioctls to be omitted Finn Thain
2015-06-28 1:42 ` [RFC v3 08/24] char/nvram: Implement NVRAM read/write methods Finn Thain
2015-06-28 1:42 ` [RFC v3 09/24] char/nvram: Use generic fixed_size_llseek() Finn Thain
2015-06-28 1:42 ` [RFC v3 10/24] m68k/atari: Implement arch_nvram_ops methods and enable CONFIG_HAVE_ARCH_NVRAM_OPS Finn Thain
2015-06-28 1:42 ` [RFC v3 11/24] char/nvram: Add "devname:nvram" module alias Finn Thain
2015-06-28 1:42 ` [RFC v3 12/24] powerpc: Cleanup nvram includes Finn Thain
2015-06-28 1:42 ` [RFC v3 13/24] powerpc: Add missing ppc_md.nvram_size for CHRP and PowerMac Finn Thain
2015-06-28 1:42 ` [RFC v3 14/24] powerpc: Implement arch_nvram_ops.get_size() and remove old nvram_* exports Finn Thain
2015-06-28 1:42 ` [RFC v3 15/24] powerpc: Implement nvram sync ioctl Finn Thain
2015-06-28 1:42 ` [RFC v3 16/24] powerpc, fbdev: Use arch_nvram_ops methods instead of nvram_read_byte() and nvram_write_byte() Finn Thain
2015-06-28 1:42 ` [RFC v3 17/24] nvram: Drop nvram_* symbol exports and prototypes Finn Thain
2015-06-28 1:42 ` [RFC v3 18/24] powerpc: Remove CONFIG_GENERIC_NVRAM and adopt CONFIG_HAVE_ARCH_NVRAM_OPS Finn Thain
2015-06-28 1:42 ` [RFC v3 19/24] char/generic_nvram: Remove as unused Finn Thain
2015-06-28 1:42 ` [RFC v3 20/24] powerpc: Adopt nvram module for PPC64 Finn Thain
2015-06-28 1:42 ` [RFC v3 21/24] m68k/mac: Adopt naming and calling conventions for PRAM routines Finn Thain
2015-06-28 1:42 ` [RFC v3 22/24] m68k/mac: Use macros for RTC accesses not magic numbers Finn Thain
2015-06-28 1:42 ` [RFC v3 23/24] m68k/mac: Fix PRAM accessors Finn Thain
2015-06-28 1:42 ` [RFC v3 24/24] m68k: Dispatch nvram_ops calls to Atari or Mac functions Finn Thain
2015-06-29 7:25 ` Geert Uytterhoeven
2015-07-02 2:07 ` Finn Thain [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LNX.2.00.1507021146530.15903@nippy.intranet \
--to=fthain@telegraphics.com.au \
--cc=geert@linux-m68k.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-m68k@vger.kernel.org \
--cc=linuxppc-dev@lists.ozlabs.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox