From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from out-176.mta1.migadu.com (out-176.mta1.migadu.com [95.215.58.176]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 674B63D3CF0; Mon, 13 Jul 2026 08:53:59 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=95.215.58.176 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1783932841; cv=none; b=DMJ/TUrJilaqI/jjGHDZdy7r9uYtzuA3GdQxnIovh7IOZPPFpZwHxYbs6YtW9WpHCj567Qg8WXKdjhHsUUtHJrP8xBmBvvUoZNBwjhnroLROa2XO2yfwvciQYCQmIAihReRpG/WAUIs4cLzsdxIsaYb5vf6w1kda67O9qZ8zfZ4= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1783932841; c=relaxed/simple; bh=JOa6K++P6fYRskwoWz6GdiFHuS+l3STV0JKn4weWjIs=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=SjK9o5XNLYNcugTLQmB+aeg/GX4tnx0IcWfaPUX5iU14AXQzgKsc/9Cw1+pUxENExM98yN+t3EE/7WoNupH1UiDlXTXes8nfgJqlfiFM6Mpxq1IFJomN0UQApnJApjIL/ddE46Mo0e1nJlmzX5o4clmOSzNnszYh3YUFrY7SCOs= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=linux.dev; spf=pass smtp.mailfrom=linux.dev; dkim=pass (1024-bit key) header.d=linux.dev header.i=@linux.dev header.b=RUIqvmAD; arc=none smtp.client-ip=95.215.58.176 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=linux.dev Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=linux.dev Authentication-Results: smtp.subspace.kernel.org; dkim=pass (1024-bit key) header.d=linux.dev header.i=@linux.dev header.b="RUIqvmAD" Message-ID: <0d439442-19b5-43b7-b4a2-1db31c5b4ebc@linux.dev> DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=linux.dev; s=key1; t=1783932835; h=from:from:reply-to:subject:subject:date:date:message-id:message-id: to:to:cc:cc:mime-version:mime-version:content-type:content-type: content-transfer-encoding:content-transfer-encoding: in-reply-to:in-reply-to:references:references; bh=zvIp+NR3qYt0PrZhDL/f2qxIy2gEc52ljxfHQCXyhr4=; b=RUIqvmADdYkety6SJEMUvPmUVl1FlTSnH4pfZO2icxTa5w3TBNYqcfBM4n1KYGDarXxqYl u40sg7a6WvMKynquAjKrvQ9QgIkjuf6AOJ80ap/o5+Tit35evljxX52dy3jOnhg65mJCLL kpz1hvGHzfnvtIiYRs5Pa0CvbZs3mMw= Date: Mon, 13 Jul 2026 16:53:29 +0800 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Subject: Re: [PATCH v8 08/10] rust: binder: use `LocalModule` for `THIS_MODULE` To: Alice Ryhl Cc: Miguel Ojeda , Boqun Feng , Gary Guo , =?UTF-8?Q?Bj=C3=B6rn_Roy_Baron?= , Benno Lossin , Andreas Hindborg , Trevor Gross , Danilo Krummrich , Luis Chamberlain , Petr Pavlu , Daniel Gomez , Sami Tolvanen , Aaron Tomlin , Greg Kroah-Hartman , "Rafael J. Wysocki" , David Airlie , Simona Vetter , Daniel Almeida , Arnd Bergmann , Brendan Higgins , David Gow , Rae Moar , Breno Leitao , Jens Axboe , Dave Ertman , Leon Romanovsky , Igor Korotin , FUJITA Tomonori , Bjorn Helgaas , =?UTF-8?Q?Krzysztof_Wilczy=C5=84ski?= , =?UTF-8?Q?Arve_Hj=C3=B8nnev=C3=A5g?= , Todd Kjos , Christian Brauner , Carlos Llamas , rust-for-linux@vger.kernel.org, linux-modules@vger.kernel.org, driver-core@lists.linux.dev, dri-devel@lists.freedesktop.org, nova-gpu@lists.linux.dev, linux-kselftest@vger.kernel.org, kunit-dev@googlegroups.com, linux-block@vger.kernel.org, linux-kernel@vger.kernel.org, netdev@vger.kernel.org, linux-pci@vger.kernel.org References: <20260713-fix-fops-owner-v8-0-2495cfa82d47@linux.dev> <20260713-fix-fops-owner-v8-8-2495cfa82d47@linux.dev> X-Report-Abuse: Please report any abuse attempt to abuse@migadu.com and include these headers. From: Alvin Sun In-Reply-To: Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 8bit X-Migadu-Flow: FLOW_OUT On 7/13/26 16:13, Alice Ryhl wrote: > On Mon, Jul 13, 2026 at 02:45:29PM +0800, Alvin Sun wrote: >> Replace the `THIS_MODULE` static reference in the binder fops with >> `this_module::()`, consistent with the move of >> `THIS_MODULE` into the `ModuleMetadata` trait. >> >> Assisted-by: opencode:glm-5.2 >> Reviewed-by: Gary Guo >> Acked-by: Danilo Krummrich >> Signed-off-by: Alvin Sun > Most other Rust Binder commits use 'rust_binder:' prefix rather than > 'rust: binder:'. I missed this prefix convention — thanks for catching it. I'll fix it in the next revision, along with any other feedback that comes in. Best regards, Alvin > > Alice