From: Dave Hansen <haveblue@us.ibm.com>
To: Matt Mackall <mpm@selenic.com>
Cc: linux-kernel@vger.kernel.org, serue@us.ibm.com
Subject: Re: [RFC][PATCH 3/5] pagemap: remove open-coded sizeof(unsigned long)
Date: Tue, 07 Aug 2007 16:55:02 -0700 [thread overview]
Message-ID: <1186530902.22283.77.camel@localhost> (raw)
In-Reply-To: <20070807234027.GE30556@waste.org>
On Tue, 2007-08-07 at 18:40 -0500, Matt Mackall wrote:
> On Tue, Aug 07, 2007 at 03:33:02PM -0700, Dave Hansen wrote:
> > +#define PAGEMAP_ENTRY_SIZE_BYTES sizeof(unsigned long)
> > +
> > static int add_to_pagemap(unsigned long addr, unsigned long pfn,
> > struct pagemapread *pm)
> > {
> > __put_user(pfn, pm->out);
> > pm->out++;
> > - pm->pos += sizeof(unsigned long);
> > - pm->count -= sizeof(unsigned long);
> > - pm->next = addr + PAGE_SIZE;
> > + pm->pos += PAGEMAP_ENTRY_SIZE_BYTES;
> > + pm->count -= PAGEMAP_ENTRY_SIZE_BYTES;
>
> I think deleting ->next is a little premature here?
It is. I'll fix that up.
-- Dave
next prev parent reply other threads:[~2007-08-07 23:55 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-08-07 22:33 [RFC][PATCH 1/5] pagemap: remove file header Dave Hansen
2007-08-07 22:33 ` [RFC][PATCH 2/5] pagemap: use PAGE_MASK/PAGE_ALIGN() Dave Hansen
2007-08-08 1:54 ` Matt Mackall
2007-08-07 22:33 ` [RFC][PATCH 3/5] pagemap: remove open-coded sizeof(unsigned long) Dave Hansen
2007-08-07 23:40 ` Matt Mackall
2007-08-07 23:55 ` Dave Hansen [this message]
2007-08-08 2:01 ` Matt Mackall
2007-08-07 22:33 ` [RFC][PATCH 4/5] introduce TASK_SIZE_OF() for all arches Dave Hansen
2007-08-08 2:03 ` Matt Mackall
2007-08-08 18:19 ` Dave Hansen
2007-08-07 22:33 ` [RFC][PATCH 5/5] pagemap: add walker for empty areas Dave Hansen
2007-08-08 1:16 ` [RFC][PATCH 1/5] pagemap: remove file header Matt Mackall
2007-08-08 1:31 ` Alan Cox
2007-08-08 3:51 ` Matt Mackall
2007-08-08 16:34 ` Dave Hansen
2007-08-08 16:53 ` Dave Hansen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1186530902.22283.77.camel@localhost \
--to=haveblue@us.ibm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mpm@selenic.com \
--cc=serue@us.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox