On Fri, 2008-05-16 at 10:10 +0200, Johannes Berg wrote: > On Fri, 2008-05-16 at 09:01 +0200, Sebastian Siewior wrote: > > * Harvey Harrison | 2008-05-15 23:17:17 [-0700]: > > > > >Make the michael_block macro a function and change the calling > > >function to take a struct michael_mic_ctx * and the value for > > >the initial xor with ctx->l. > > > > > >Also open-code xswap in its one use in michael_block. > > Does this change have any performance impact? > > The only user is wireless (I guess). Is it used frequently (sign every > > packet for instance) or once in a while (in every re-keying)? > > Every packet. I have no idea whether it has performance impact, very > hard to even guess. > Well, the code-size difference is significant (about 200 bytes smaller on X86-32). This macro is essentially an inline function that is pretty large. Attached find the objdump -d of the original and after the patch. As it is, this code isn't used anywhere that I can find as mac80211 has its own implementation, I'm trying to see if there is much advantage in keeping the private version over moving to the crypto one. Harvey