From: Nigel Cunningham <ncunningham@crca.org.au>
To: Kevin Winchester <kjwinchester@gmail.com>,
Roland Dreier <rdreier@cisco.com>
Cc: Ingo Molnar <mingo@redhat.com>,
Thomas Gleixner <tglx@linutronix.de>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: Latest git compile error: arch/x86/lib/csum-copy_64.S:48: Error: Macro `ignore' was already defined
Date: Tue, 15 Jul 2008 12:34:06 +1000 [thread overview]
Message-ID: <1216089246.25534.47.camel@nigel-laptop> (raw)
In-Reply-To: <487BF0FD.60200@gmail.com>
Hi.
On Mon, 2008-07-14 at 21:36 -0300, Kevin Winchester wrote:
> Hi Ingo, Thomas,
>
> I get the following when trying to compile the latest source from
> Linus'
> tree:
>
> AS arch/x86/lib/csum-copy_64.o
> arch/x86/lib/csum-copy_64.S: Assembler messages:
> arch/x86/lib/csum-copy_64.S:48: Error: Macro `ignore' was already
> defined
> make[1]: *** [arch/x86/lib/csum-copy_64.o] Error 1
> make: *** [arch/x86/lib] Error 2
>
>
> It appears that csum-copy_64.S and dwarf2.h both define an ignore
> macro.
> I would expect one of them can be renamed quite easily, unless they
> are references elsewhere. Something like (whitespace damaged I know,
> it's just for example):
>
> diff --git a/include/asm-x86/dwarf2.h b/include/asm-x86/dwarf2.h
> index 0bfe250..738bb9f 100644
> --- a/include/asm-x86/dwarf2.h
> +++ b/include/asm-x86/dwarf2.h
> @@ -38,23 +38,23 @@
>
> /* Due to the structure of pre-exisiting code, don't use assembler
> line
> comment character # to ignore the arguments. Instead, use a
> dummy
> macro. */
> -.macro ignore a=0, b=0, c=0, d=0
> +.macro cfi_ignore a=0, b=0, c=0, d=0
> .endm
>
> -#define CFI_STARTPROC ignore
> -#define CFI_ENDPROC ignore
> -#define CFI_DEF_CFA ignore
> -#define CFI_DEF_CFA_REGISTER ignore
> -#define CFI_DEF_CFA_OFFSET ignore
> -#define CFI_ADJUST_CFA_OFFSET ignore
> -#define CFI_OFFSET ignore
> -#define CFI_REL_OFFSET ignore
> -#define CFI_REGISTER ignore
> -#define CFI_RESTORE ignore
> -#define CFI_REMEMBER_STATE ignore
> -#define CFI_RESTORE_STATE ignore
> -#define CFI_UNDEFINED ignore
> -#define CFI_SIGNAL_FRAME ignore
> +#define CFI_STARTPROC cfi_ignore
> +#define CFI_ENDPROC cfi_ignore
> +#define CFI_DEF_CFA cfi_ignore
> +#define CFI_DEF_CFA_REGISTER cfi_ignore
> +#define CFI_DEF_CFA_OFFSET cfi_ignore
> +#define CFI_ADJUST_CFA_OFFSET cfi_ignore
> +#define CFI_OFFSET cfi_ignore
> +#define CFI_REL_OFFSET cfi_ignore
> +#define CFI_REGISTER cfi_ignore
> +#define CFI_RESTORE cfi_ignore
> +#define CFI_REMEMBER_STATE cfi_ignore
> +#define CFI_RESTORE_STATE cfi_ignore
> +#define CFI_UNDEFINED cfi_ignore
> +#define CFI_SIGNAL_FRAME cfi_ignore
>
> #endif
Compiles okay here and boots okay under VMware.
Tested-by: Nigel Cunningham <nigel@tuxonice.net>
Regards,
Nigel
prev parent reply other threads:[~2008-07-15 2:36 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-07-15 0:36 Latest git compile error: arch/x86/lib/csum-copy_64.S:48: Error: Macro `ignore' was already defined Kevin Winchester
2008-07-15 2:34 ` Nigel Cunningham [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1216089246.25534.47.camel@nigel-laptop \
--to=ncunningham@crca.org.au \
--cc=kjwinchester@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=rdreier@cisco.com \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox