From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755502Ab1CWFJo (ORCPT ); Wed, 23 Mar 2011 01:09:44 -0400 Received: from mailout-de.gmx.net ([213.165.64.23]:52384 "HELO mailout-de.gmx.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with SMTP id S1755064Ab1CWFJn (ORCPT ); Wed, 23 Mar 2011 01:09:43 -0400 X-Authenticated: #14349625 X-Provags-ID: V01U2FsdGVkX1/sCxlzg8DsO4JX1M1Cv8vApnT648dLUOkZSKlqTm rO2QN3ZwDn3lnY Subject: Re: [patch 04/15] sched: throttle cfs_rq entities which exceed their local quota From: Mike Galbraith To: Paul Turner Cc: linux-kernel@vger.kernel.org, Peter Zijlstra , Bharata B Rao , Dhaval Giani , Balbir Singh , Vaidyanathan Srinivasan , Srivatsa Vaddagiri , Kamalesh Babulal , Ingo Molnar , Pavel Emelyanov , Nikhil Rao In-Reply-To: <20110323030449.047028257@google.com> References: <20110323030326.789836913@google.com> <20110323030449.047028257@google.com> Content-Type: text/plain; charset="UTF-8" Date: Wed, 23 Mar 2011 06:09:36 +0100 Message-ID: <1300856976.7492.44.camel@marge.simson.net> Mime-Version: 1.0 X-Mailer: Evolution 2.32.1 Content-Transfer-Encoding: 7bit X-Y-GMX-Trusted: 0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 2011-03-22 at 20:03 -0700, Paul Turner wrote: > +static void check_cfs_rq_quota(struct cfs_rq *cfs_rq) > +{ > + if (within_bandwidth(cfs_rq)) > + return; > + > + Nit: It'd be nice if classes agreed on naming convention to ease rummaging. In rt, it's bandwidth for bean counting parameters, but the beans are runtime. within_bandwidth() vs sched_rt_runtime_exceeded() kinda pokes me in the eye when I look at the total. Seems to me it should be uniformly either quota or bandwidth, and uniformly runtime. -Mike