From: Peter Zijlstra <peterz@infradead.org>
To: Greg KH <greg@kroah.com>
Cc: Daniel Baluta <dbaluta@ixiacom.com>, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] kref: add function for reading kref value
Date: Mon, 12 Dec 2011 16:28:57 +0100 [thread overview]
Message-ID: <1323703737.21400.3.camel@twins> (raw)
In-Reply-To: <20111212150255.GA7506@kroah.com>
On Mon, 2011-12-12 at 07:02 -0800, Greg KH wrote:
> On Mon, Dec 12, 2011 at 02:44:52PM +0200, Daniel Baluta wrote:
> > We can easily get kref refcount value by accesing
> > kref->refcount but it is better to have a function
> > for this.
>
> No, you should NEVER need the value of the kref, if you do, you are
> doing something wrong.
>
> What code needs this patch?
I very much agree with Greg, those sites that know wth they're doing are
way better off open-coding it like they do now. (I only looked at the
neihgbour.c one, which is creative but not evidently wrong).
Providing a kref_read() function however, suggests its actually a sane
thing to do, its not.
prev parent reply other threads:[~2011-12-12 15:29 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-12-12 12:44 [PATCH] kref: add function for reading kref value Daniel Baluta
2011-12-12 12:51 ` Belisko Marek
2011-12-12 12:55 ` Daniel Baluta
2011-12-12 13:41 ` Daniel Baluta
2011-12-12 15:09 ` Alexey Dobriyan
2011-12-12 15:02 ` Greg KH
2011-12-12 15:21 ` Daniel Baluta
2011-12-12 15:32 ` Eric Dumazet
2011-12-12 15:39 ` Daniel Baluta
2011-12-12 15:41 ` Eric Dumazet
2011-12-12 16:42 ` Daniel Baluta
2011-12-12 17:33 ` Greg KH
2011-12-12 17:46 ` Daniel Baluta
2011-12-12 17:57 ` Eric Dumazet
2011-12-12 18:33 ` Greg KH
2011-12-12 17:42 ` Eric Dumazet
2011-12-12 15:28 ` Peter Zijlstra [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1323703737.21400.3.camel@twins \
--to=peterz@infradead.org \
--cc=dbaluta@ixiacom.com \
--cc=greg@kroah.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox