From: Joe Perches <joe@perches.com>
To: Greg KH <gregkh@linuxfoundation.org>, Jason Baron <jbaron@akamai.com>
Cc: shigekatsu.tateno@atmel.com, devel@linuxdriverproject.org,
linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] staging: ozwpan: Convert printk to dev_dbg()
Date: Tue, 25 Jun 2013 11:03:09 -0700 [thread overview]
Message-ID: <1372183389.1245.74.camel@joe-AO722> (raw)
In-Reply-To: <1372183005.1245.72.camel@joe-AO722>
(Using Jason Baron's most current email address)
On Tue, 2013-06-25 at 10:56 -0700, Joe Perches wrote:
> On Tue, 2013-06-25 at 10:38 -0700, Greg KH wrote:
> > On Tue, Jun 25, 2013 at 10:29:50AM -0700, Joe Perches wrote:
> > > a long needed extension to dev_dbg is to enable classes
> > > of messages by level or mask.
> > >
> > > There are many existing macros like
> > >
> > > #define module_dbg(level, fmt, ...)
> > > do {
> > > if (level >= some_module_var)
> > > debug_something(...);
> > > } while (0)
> > >
> > > and
> > >
> > > #define module_dbg(mask, fmt, ...)
> > > do {
> > > if (mask & some_module_var)
> > > debug_something(...)
> > > } while (0)
> > >
> > > It'd be nice to consolidate those in dev_dbg
> >
> > I'd almost recommend that all of them just be removed, because most of
> > them were only used for debugging the code the first time it was
> > developed, right? Only for very limited usages would this type of thing
> > be needed.
>
> Maybe, though that's hard to know with certainty.
> How often module options are used isn't easy to find out.
>
> These forms are sometimes used to reduce object size.
Hey Jason. Your redhat.com address is out of date.
If you're still interested in dynamic_debug, you should
update your MAINTAINERS entry.
next prev parent reply other threads:[~2013-06-25 18:03 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-06-25 16:30 [PATCH] staging: ozwpan: Convert printk to dev_dbg() Rupesh Gujare
2013-06-25 16:40 ` Joe Perches
2013-06-25 17:02 ` Greg KH
2013-06-25 17:29 ` Joe Perches
2013-06-25 17:38 ` Greg KH
2013-06-25 17:56 ` Joe Perches
2013-06-25 18:03 ` Joe Perches [this message]
2013-06-26 17:51 ` Jason Baron
2013-06-26 1:00 ` [PATCH] staging: ozwpan: Use normal Makefile, convert oz_trace to oz_dbg Joe Perches
2013-06-26 11:53 ` Rupesh Gujare
2013-06-26 13:56 ` Joe Perches
2013-06-26 14:19 ` Joe Perches
2013-07-04 12:35 ` [PATCH v2 0/5] Replace debug macro Rupesh Gujare
2013-07-04 14:31 ` Joe Perches
2013-07-04 12:35 ` [PATCH v2 1/5] staging: ozwpan: Remove extra debug logs Rupesh Gujare
2013-07-04 12:35 ` [PATCH v2 2/5] staging: ozwpan: Replace oz_trace with oz_dbg Rupesh Gujare
2013-07-04 12:35 ` [PATCH v2 3/5] staging: ozwpan: Remove old debug macro Rupesh Gujare
2013-07-04 12:35 ` [PATCH v2 4/5] staging: ozwpan: Convert macro to function Rupesh Gujare
2013-07-04 12:35 ` [PATCH v2 5/5] staging: ozwpan: Rename Kbuild to Makefile Rupesh Gujare
2013-07-04 12:45 ` Rupesh Gujare
2013-07-22 17:43 ` Rupesh Gujare
2013-07-22 17:55 ` Greg Kroah-Hartman
2013-07-22 22:08 ` Gujare, Rupesh
2013-07-23 12:44 ` [PATCH v3 0/5] staging: ozwpan: Replace debug macro Rupesh Gujare
2013-07-23 12:44 ` [PATCH v3 1/5] staging: ozwpan: Remove extra debug logs Rupesh Gujare
2013-07-23 12:45 ` [PATCH v3 2/5] staging: ozwpan: Replace oz_trace with oz_dbg Rupesh Gujare
2013-07-23 12:45 ` [PATCH v3 3/5] staging: ozwpan: Remove old debug macro Rupesh Gujare
2013-07-23 12:45 ` [PATCH v3 4/5] staging: ozwpan: Convert macro to function Rupesh Gujare
2013-07-23 12:45 ` [PATCH v3 5/5] staging: ozwpan: Rename Kbuild to Makefile Rupesh Gujare
2013-06-26 17:46 ` [PATCH] staging: ozwpan: Convert printk to dev_dbg() Jason Baron
2013-06-27 0:26 ` Joe Perches
2013-06-25 17:49 ` Rupesh Gujare
2013-06-25 17:55 ` Alan Stern
2013-06-25 17:57 ` Greg KH
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1372183389.1245.74.camel@joe-AO722 \
--to=joe@perches.com \
--cc=devel@linuxdriverproject.org \
--cc=gregkh@linuxfoundation.org \
--cc=jbaron@akamai.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=shigekatsu.tateno@atmel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox