From: Joe Perches <joe@perches.com>
To: Rupesh Gujare <rupesh.gujare@atmel.com>
Cc: devel@linuxdriverproject.org, dan.carpenter@oracle.com,
linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org,
gregkh@linuxfoundation.org
Subject: Re: [PATCH 09/10] staging: ozwpan: Swap arguments of oz_ep_alloc() to match kmalloc()
Date: Tue, 13 Aug 2013 10:35:49 -0700 [thread overview]
Message-ID: <1376415349.1949.40.camel@joe-AO722> (raw)
In-Reply-To: <1376414966-23525-5-git-send-email-rupesh.gujare@atmel.com>
On Tue, 2013-08-13 at 18:29 +0100, Rupesh Gujare wrote:
> Swap arguments of oz_ep_alloc() to match kmalloc() for better readability.
[]
> diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan/ozhcd.c
[]
> -static struct oz_endpoint *oz_ep_alloc(gfp_t mem_flags, int buffer_size)
> +static struct oz_endpoint *oz_ep_alloc(int buffer_size, gfp_t mem_flags)
could use size_t buffer_size instead.
next prev parent reply other threads:[~2013-08-13 17:35 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-08-13 17:29 [PATCH 05/10] staging: ozwpan: Remove unnecessary pointer check Rupesh Gujare
2013-08-13 17:29 ` [PATCH 06/10] staging: ozwpan: Make oz_hcd_pd_arrived() return a struct pointer Rupesh Gujare
2013-08-13 17:29 ` [PATCH 07/10] staging: ozwpan: Make oz_hcd_pd_departed() take " Rupesh Gujare
2013-08-13 17:35 ` Sergei Shtylyov
2013-08-13 17:40 ` Rupesh Gujare
2013-08-13 17:46 ` Sergei Shtylyov
2013-08-14 21:31 ` Dan Carpenter
2013-08-13 17:29 ` [PATCH 08/10] staging: ozwpan: Remove unneeded initializers Rupesh Gujare
2013-08-13 17:29 ` [PATCH 09/10] staging: ozwpan: Swap arguments of oz_ep_alloc() to match kmalloc() Rupesh Gujare
2013-08-13 17:35 ` Joe Perches [this message]
2013-08-13 17:29 ` [PATCH 10/10] staging: ozwpan: Separate success & failure case for oz_hcd_pd_arrived() Rupesh Gujare
2013-08-13 23:00 ` Dan Carpenter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1376415349.1949.40.camel@joe-AO722 \
--to=joe@perches.com \
--cc=dan.carpenter@oracle.com \
--cc=devel@linuxdriverproject.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=rupesh.gujare@atmel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox