From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756555AbbDOWBy (ORCPT ); Wed, 15 Apr 2015 18:01:54 -0400 Received: from mx0b-00082601.pphosted.com ([67.231.153.30]:11794 "EHLO mx0a-00082601.pphosted.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1752916AbbDOWBo (ORCPT ); Wed, 15 Apr 2015 18:01:44 -0400 From: Jens Axboe To: , Subject: [PATCH v2] direct-io: only inc/dec inode->i_dio_count for file systems Date: Wed, 15 Apr 2015 16:01:35 -0600 Message-ID: <1429135298-17153-1-git-send-email-axboe@fb.com> X-Mailer: git-send-email 1.9.1 MIME-Version: 1.0 Content-Type: text/plain X-Originating-IP: [192.168.54.13] X-Proofpoint-Spam-Reason: safe X-FB-Internal: Safe X-Proofpoint-Virus-Version: vendor=fsecure engine=2.50.10432:5.13.68,1.0.33,0.0.0000 definitions=2015-04-15_07:2015-04-15,2015-04-15,1970-01-01 signatures=0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi, A proper patch series posting of the patch to skip inode dio counts where we don't need them. Performance results and general notes in patch #1. We can take this a bit further if we want to push this truncate locking into the caller, but I'd like to keep that as a separate patch series instead. Changes since v2: - Changed flag to DIO_SKIP_DIO_COUNT. Patch 2+3 will use this for skipping the extra inc/dec for btrfs and ext4, so better rename it to something that better tells what is happening in the deep mess that is dio. - Have inode_dio_inc/dec() helpers. Again, this better tells the caller what is going on. -- Jens Axboe