From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753959AbcGSPmV (ORCPT ); Tue, 19 Jul 2016 11:42:21 -0400 Received: from mail-pa0-f65.google.com ([209.85.220.65]:36062 "EHLO mail-pa0-f65.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752366AbcGSPmL (ORCPT ); Tue, 19 Jul 2016 11:42:11 -0400 From: Andrey Smirnov To: linux-mtd@lists.infradead.org Cc: Andrey Smirnov , Boris Brezillon , Richard Weinberger , David Woodhouse , Brian Norris , linux-kernel@vger.kernel.org Subject: [PATCH 2/2] mtd: nand: Get rid of needless 'goto' Date: Tue, 19 Jul 2016 08:41:44 -0700 Message-Id: <1468942904-26464-2-git-send-email-andrew.smirnov@gmail.com> X-Mailer: git-send-email 2.5.5 In-Reply-To: <1468942904-26464-1-git-send-email-andrew.smirnov@gmail.com> References: <1468942904-26464-1-git-send-email-andrew.smirnov@gmail.com> Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Using "goto" in that "switch" statement only makes it harder to follow control flow and doesn't bring any advantages. Rewrite the code to avoid using "goto". Signed-off-by: Andrey Smirnov --- drivers/mtd/nand/nand_base.c | 13 +++++-------- 1 file changed, 5 insertions(+), 8 deletions(-) diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c index 57043a6..8fa5536 100644 --- a/drivers/mtd/nand/nand_base.c +++ b/drivers/mtd/nand/nand_base.c @@ -2139,18 +2139,15 @@ static int nand_read_oob(struct mtd_info *mtd, loff_t from, case MTD_OPS_PLACE_OOB: case MTD_OPS_AUTO_OOB: case MTD_OPS_RAW: + if (!ops->datbuf) + ret = nand_do_read_oob(mtd, from, ops); + else + ret = nand_do_read_ops(mtd, from, ops); break; - default: - goto out; + break; } - if (!ops->datbuf) - ret = nand_do_read_oob(mtd, from, ops); - else - ret = nand_do_read_ops(mtd, from, ops); - -out: nand_release_device(mtd); return ret; } -- 2.5.5