From: Pawel Laszczak <pawell@cadence.com>
To: <devicetree@vger.kernel.org>
Cc: <gregkh@linuxfoundation.org>, <mark.rutland@arm.com>,
<linux-usb@vger.kernel.org>, <hdegoede@redhat.com>,
<heikki.krogerus@linux.intel.com>, <andy.shevchenko@gmail.com>,
<robh+dt@kernel.org>, <rogerq@ti.com>,
<linux-kernel@vger.kernel.org>, <adouglas@cadence.com>,
<jbergsagel@ti.com>, <nsekhar@ti.com>, <nm@ti.com>,
<sureshp@cadence.com>, <peter.chen@nxp.com>, <pjez@cadence.com>,
<kurahul@cadence.com>, Pawel Laszczak <pawell@cadence.com>
Subject: [PATCH v2 3/5] usb:common Patch simplify usb_decode_set_clear_feature function.
Date: Sun, 23 Dec 2018 15:13:10 +0000 [thread overview]
Message-ID: <1545577992-4013-4-git-send-email-pawell@cadence.com> (raw)
In-Reply-To: <1545577992-4013-1-git-send-email-pawell@cadence.com>
Patch adds usb_decode_test_mode and usb_decode_device_feature functions,
which allow to make more readable and simplify the
usb_decode_set_clear_feature function.
Signed-off-by: Pawel Laszczak <pawell@cadence.com>
---
drivers/usb/common/debug.c | 83 ++++++++++++++++++--------------------
1 file changed, 40 insertions(+), 43 deletions(-)
diff --git a/drivers/usb/common/debug.c b/drivers/usb/common/debug.c
index 374fb9e94f37..77e565a38f29 100644
--- a/drivers/usb/common/debug.c
+++ b/drivers/usb/common/debug.c
@@ -29,6 +29,44 @@ static void usb_decode_get_status(__u8 bRequestType, __u16 wIndex,
}
}
+static const char *usb_decode_device_feature(u16 wValue)
+{
+ switch (wValue) {
+ case USB_DEVICE_SELF_POWERED:
+ return "Self Powered";
+ case USB_DEVICE_REMOTE_WAKEUP:
+ return "Remote Wakeup";
+ case USB_DEVICE_TEST_MODE:
+ return "Test Mode";
+ case USB_DEVICE_U1_ENABLE:
+ return "U1 Enable";
+ case USB_DEVICE_U2_ENABLE:
+ return "U2 Enable";
+ case USB_DEVICE_LTM_ENABLE:
+ return "LTM Enable";
+ default:
+ return "UNKNOWN";
+ }
+}
+
+static const char *usb_decode_test_mode(u16 wIndex)
+{
+ switch (wIndex) {
+ case TEST_J:
+ return ": TEST_J";
+ case TEST_K:
+ return ": TEST_K";
+ case TEST_SE0_NAK:
+ return ": TEST_SE0_NAK";
+ case TEST_PACKET:
+ return ": TEST_PACKET";
+ case TEST_FORCE_EN:
+ return ": TEST_FORCE_EN";
+ default:
+ return ": UNKNOWN";
+ }
+}
+
static void usb_decode_set_clear_feature(__u8 bRequestType,
__u8 bRequest, __u16 wValue,
__u16 wIndex, char *str)
@@ -37,50 +75,9 @@ static void usb_decode_set_clear_feature(__u8 bRequestType,
case USB_RECIP_DEVICE:
sprintf(str, "%s Device Feature(%s%s)",
bRequest == USB_REQ_CLEAR_FEATURE ? "Clear" : "Set",
- ({char *s;
- switch (wValue) {
- case USB_DEVICE_SELF_POWERED:
- s = "Self Powered";
- break;
- case USB_DEVICE_REMOTE_WAKEUP:
- s = "Remote Wakeup";
- break;
- case USB_DEVICE_TEST_MODE:
- s = "Test Mode";
- break;
- case USB_DEVICE_U1_ENABLE:
- s = "U1 Enable";
- break;
- case USB_DEVICE_U2_ENABLE:
- s = "U2 Enable";
- break;
- case USB_DEVICE_LTM_ENABLE:
- s = "LTM Enable";
- break;
- default:
- s = "UNKNOWN";
- } s; }),
+ usb_decode_device_feature(wValue),
wValue == USB_DEVICE_TEST_MODE ?
- ({ char *s;
- switch (wIndex) {
- case TEST_J:
- s = ": TEST_J";
- break;
- case TEST_K:
- s = ": TEST_K";
- break;
- case TEST_SE0_NAK:
- s = ": TEST_SE0_NAK";
- break;
- case TEST_PACKET:
- s = ": TEST_PACKET";
- break;
- case TEST_FORCE_EN:
- s = ": TEST_FORCE_EN";
- break;
- default:
- s = ": UNKNOWN";
- } s; }) : "");
+ usb_decode_test_mode(wIndex) : "");
break;
case USB_RECIP_INTERFACE:
sprintf(str, "%s Interface Feature(%s)",
--
2.17.1
next prev parent reply other threads:[~2018-12-23 15:15 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-12-23 15:13 [PATCH v2 0/5] Introduced new Cadence USBSS DRD Driver Pawel Laszczak
2018-12-23 15:13 ` [PATCH v2 1/5] dt-bindings: add binding for USBSS-DRD controller Pawel Laszczak
2018-12-23 15:13 ` [PATCH v2 2/5] usb:common Separated decoding functions from dwc3 driver Pawel Laszczak
2018-12-23 15:13 ` Pawel Laszczak [this message]
2018-12-23 15:13 ` [PATCH v2 4/5] usb:common Simplify usb_decode_get_set_descriptor function Pawel Laszczak
2018-12-23 15:13 ` [PATCH v2 5/5] usb:cdns3 Add Cadence USB3 DRD Driver Pawel Laszczak
2018-12-23 17:19 ` Randy Dunlap
2018-12-23 19:20 ` kbuild test robot
2018-12-31 9:42 ` Pawel Laszczak
2018-12-24 9:38 ` Peter Chen
2018-12-25 9:38 ` Peter Chen
2018-12-27 9:36 ` Pawel Laszczak
2018-12-28 1:31 ` Peter Chen
2018-12-31 5:32 ` Pawel Laszczak
2018-12-27 13:11 ` Pawel Laszczak
2018-12-29 7:41 ` Chunfeng Yun
2018-12-31 12:31 ` Pawel Laszczak
2019-01-10 1:30 ` Peter Chen
2019-01-10 6:57 ` Greg Kroah-Hartman
2019-01-10 7:18 ` Pawel Laszczak
2019-01-02 6:44 ` [PATCH v2 0/5] Introduced new Cadence USBSS " Peter Chen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1545577992-4013-4-git-send-email-pawell@cadence.com \
--to=pawell@cadence.com \
--cc=adouglas@cadence.com \
--cc=andy.shevchenko@gmail.com \
--cc=devicetree@vger.kernel.org \
--cc=gregkh@linuxfoundation.org \
--cc=hdegoede@redhat.com \
--cc=heikki.krogerus@linux.intel.com \
--cc=jbergsagel@ti.com \
--cc=kurahul@cadence.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=nm@ti.com \
--cc=nsekhar@ti.com \
--cc=peter.chen@nxp.com \
--cc=pjez@cadence.com \
--cc=robh+dt@kernel.org \
--cc=rogerq@ti.com \
--cc=sureshp@cadence.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox