The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Ashok Raj <ashok.raj@intel.com>
To: Andi Kleen <ak@muc.de>
Cc: akpm@osdl.org, ashok.raj@intel.com, linux-kernel@vger.kernel.org
Subject: Re: [patch 13/14] x86_64: Use common functions in cluster and physflat mode
Date: Tue, 6 Sep 2005 16:12:15 -0700	[thread overview]
Message-ID: <20050906161215.B19592@unix-os.sc.intel.com> (raw)
In-Reply-To: <20050905231628.GA16476@muc.de>; from ak@muc.de on Tue, Sep 06, 2005 at 01:16:28AM +0200

On Tue, Sep 06, 2005 at 01:16:28AM +0200, Andi Kleen wrote:
> On Sat, Sep 03, 2005 at 02:33:30PM -0700, akpm@osdl.org wrote:
> > 
> > From: Ashok Raj <ashok.raj@intel.com>
> > 
> > Newly introduced physflat_* shares way too much with cluster with only a very
> > differences.  So we introduce some common functions in that can be reused in
> > both cases.
> > 
> > In addition the following are also fixed.
> > - Use of non-existent CONFIG_CPU_HOTPLUG option renamed to actual one in use.
> > - Removed comment that ACPI would provide a way to select this dynamically
> >   since ACPI_CONFIG_HOTPLUG_CPU already exists that indicates platform support
> >   for hotplug via ACPI. In addition CONFIG_HOTPLUG_CPU only indicates logical 
> >   offline/online which is even used by Suspend/Resume folks where the same 
> >   support (for no-broadcast) is required.
> 
> 
> (hmm did I reply to that? I think I did but my mailer seems to have
> lost the r flag. My apologies if it's a duplicate) 
> 
> I didn't like that one because it makes the code less readable than
> before imho. I did a separate patch for the CPU_HOTPLUG typo.

The code is less readable? Now iam confused. Attached the link to patch
below to refresh your memory.

http://marc.theaimsgroup.com/?l=linux-kernel&m=112293577309653&w=2

diffstat would show we have fewer lines ~40 less lines of code. physflat
basicaly copied/cloned some useful code in cluster and some from flat mode
genapic code. 

I would have consolidated the code in the first place when you put the physflat
mode. Again this was just my habit, cant step over code bloat and duplication.

Which part of the code is unreadable to you? If you are happy with just renamed
functions with copied body of the code which is what physflat did, thats fine.

I was just puzzeled at the convoluted and less readable part of the code. If 
there is something you like to point out, i would be happy to fix it.. or you 
can if you prefer it that way.


-- 
Cheers,
Ashok Raj
- Open Source Technology Center

       reply	other threads:[~2005-09-06 23:12 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <200509032135.j83LZ8gX020554@shell0.pdx.osdl.net>
     [not found] ` <20050905231628.GA16476@muc.de>
2005-09-06 23:12   ` Ashok Raj [this message]
2005-09-09 17:07     ` [patch 13/14] x86_64: Use common functions in cluster and physflat mode Zwane Mwaikambo
2005-09-09 20:45       ` Ashok Raj
2005-09-11 16:44         ` Zwane Mwaikambo
2005-09-11 23:02           ` Andi Kleen
2005-09-12 22:23             ` Ashok Raj
2005-09-13  8:10               ` Andi Kleen
2005-09-13 14:53                 ` Zwane Mwaikambo
2005-09-13 15:31                   ` Andi Kleen
2005-09-10  0:30       ` Andi Kleen
2005-09-10  1:51         ` Zwane Mwaikambo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20050906161215.B19592@unix-os.sc.intel.com \
    --to=ashok.raj@intel.com \
    --cc=ak@muc.de \
    --cc=akpm@osdl.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox