The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Cyrill Gorcunov <gorcunov@gmail.com>
To: Ingo Molnar <mingo@elte.hu>
Cc: "Maciej W. Rozycki" <macro@linux-mips.org>,
	"H. Peter Anvin" <hpa@zytor.com>,
	LKML <linux-kernel@vger.kernel.org>,
	Thomas Gleixner <tglx@linutronix.de>
Subject: Re: [RFC] x86: io-apic - convert DO_ACTION macro into function
Date: Mon, 8 Sep 2008 18:42:42 +0400	[thread overview]
Message-ID: <20080908144242.GA7278@lenovo> (raw)
In-Reply-To: <20080908143335.GD10580@elte.hu>

[Ingo Molnar - Mon, Sep 08, 2008 at 04:33:35PM +0200]
| 
| * Cyrill Gorcunov <gorcunov@gmail.com> wrote:
| 
| > Convert DO_ACTION macro into more obvious io_apic_modify_irq
| > function with callers
| > ---
| > 
| >  I found it more readable then original was. Especialy we could grep 
| > the callers in normal way. It's just an attempt - free to drop this 
| > patch. I hope I don't messed with all these masks :) So the question 
| > is rather NOT about details but idea in general.
| 
| yeah - getting rid of such macros is a very good idea in general.
| 
| >  io_apic.c |  102 ++++++++++++++++++++++++++++++--------------------------------
| >  1 file changed, 50 insertions(+), 52 deletions(-)
| 
| that's non-trivial impact. Did the .o md5sum survive this transformation 
| just fine? (in theory gcc should generate the same code - but it doesnt 
| always do that across macro->inline function changes, so it's hard to 
| validate these kinds of changes.)
| 
| 	Ingo
| 

ok, then I continue to work on this. I think I better check assembly code
to remain the same (in general since for example new for(;;) form is
completely different - in old code is inspired by the macroses who
could change 'entry' variable in theory - but now it will not be possible
and not needed so we could use more 'eye-candy' for(;;) form). Thanks
for comments.

		- Cyrill -

      reply	other threads:[~2008-09-08 14:45 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-09-07 19:26 [RFC] x86: io-apic - convert DO_ACTION macro into function Cyrill Gorcunov
2008-09-08 14:33 ` Ingo Molnar
2008-09-08 14:42   ` Cyrill Gorcunov [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20080908144242.GA7278@lenovo \
    --to=gorcunov@gmail.com \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=macro@linux-mips.org \
    --cc=mingo@elte.hu \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox