From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932213Ab3FROhe (ORCPT ); Tue, 18 Jun 2013 10:37:34 -0400 Received: from mail-pa0-f42.google.com ([209.85.220.42]:64944 "EHLO mail-pa0-f42.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752541Ab3FROhc (ORCPT ); Tue, 18 Jun 2013 10:37:32 -0400 Date: Tue, 18 Jun 2013 07:37:28 -0700 From: Tejun Heo To: Akinobu Mita Cc: linux-kernel@vger.kernel.org, akpm@linux-foundation.org, Imre Deak , Herbert Xu , "David S. Miller" , linux-crypto@vger.kernel.org, "James E.J. Bottomley" , Douglas Gilbert , linux-scsi@vger.kernel.org Subject: Re: [PATCH v2 2/4] lib/scatterlist: introduce sg_pcopy_from_buffer() and sg_pcopy_to_buffer() Message-ID: <20130618143728.GE2767@htj.dyndns.org> References: <1371562294-13642-1-git-send-email-akinobu.mita@gmail.com> <1371562294-13642-3-git-send-email-akinobu.mita@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1371562294-13642-3-git-send-email-akinobu.mita@gmail.com> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Jun 18, 2013 at 10:31:32PM +0900, Akinobu Mita wrote: > /** > + * sg_miter_seek - reposition mapping iterator > + * @miter: sg mapping iter to be seeked > + * @offset: number of bytes to plus the current location > + * > + * Description: > + * Sets the offset of @miter to its current location plus @offset bytes. > + * > + * Notes: > + * This function must be called just after sg_miter_start() or sg_miter_stop() It's not gonna be hard to make this function to handle any state, right? Wouldn't it be better to do that? It's a pretty generic feature after all. Also, maybe a better name is sg_miter_skip()? Thanks. -- tejun