From: Jean-Francois Moine <moinejf@free.fr>
To: "Li.Xiubo@freescale.com" <Li.Xiubo@freescale.com>
Cc: Kuninori Morimoto <kuninori.morimoto.gx@gmail.com>,
"alsa-devel@alsa-project.org" <alsa-devel@alsa-project.org>,
"kuninori.morimoto.gx@renesas.com"
<kuninori.morimoto.gx@renesas.com>,
"lgirdwood@gmail.com" <lgirdwood@gmail.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"broonie@kernel.org" <broonie@kernel.org>
Subject: Re: [alsa-devel] [RFC][PATCH] ASoC: simple-card: Add asoc_simple_card_data for the simple card driver data
Date: Tue, 14 Jan 2014 12:09:13 +0100 [thread overview]
Message-ID: <20140114120913.19d883fe@armhf> (raw)
In-Reply-To: <96cb876ff05c4062ab5a2c92fb7b3c41@BY2PR03MB505.namprd03.prod.outlook.com>
On Tue, 14 Jan 2014 07:56:32 +0000
"Li.Xiubo@freescale.com" <Li.Xiubo@freescale.com> wrote:
>
> > > Whether the dt is used or not, almost all the simple card information
> > > for the DAI link and sound card are initialized in the simple card driver.
> > >
> > > And for the platform caller, the snd_link and snd_card are of no use, so
> > > move them from struct asoc_simple_card_info to struct asoc_simple_card_data.
> > >
> > > And now only one DAI link is supported for simple card.
> > >
> > > Suggested-by: Jean-Francois Moine <moinejf@free.fr>
> > > Signed-off-by: Xiubo Li <Li.Xiubo@freescale.com>
> > > ---
> >
> > This patch seems have many this kind of lines
> > - info->xxx
> > + sdata->info->xxx
> >
> > But, how about add this line to each function ?
> >
> > struct asoc_simple_card_info *info = &sdata->info;
> >
> > Patch will be more readable
> >
>
> Yes, that's looks perfect.
>
> See the next version please.
Please, don't work on an other version. I am preparing an other patch which will do quite the same as yours, but which will be easier to extend to many DAI links.
--
Ken ar c'hentañ | ** Breizh ha Linux atav! **
Jef | http://moinejf.free.fr/
next prev parent reply other threads:[~2014-01-14 11:09 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-01-14 5:44 [RFC][PATCH] ASoC: simple-card: Add asoc_simple_card_data for the simple card driver data Xiubo Li
2014-01-14 6:59 ` [alsa-devel] " Kuninori Morimoto
2014-01-14 7:56 ` Li.Xiubo
2014-01-14 11:09 ` Jean-Francois Moine [this message]
2014-01-14 14:43 ` Li.Xiubo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140114120913.19d883fe@armhf \
--to=moinejf@free.fr \
--cc=Li.Xiubo@freescale.com \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@kernel.org \
--cc=kuninori.morimoto.gx@gmail.com \
--cc=kuninori.morimoto.gx@renesas.com \
--cc=lgirdwood@gmail.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox