The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Peter Chen <peter.chen@freescale.com>
To: Antoine Tenart <antoine.tenart@free-electrons.com>
Cc: <balbi@ti.com>, <gregkh@linuxfoundation.org>, <kishon@ti.com>,
	<stern@rowland.harvard.edu>, <sergei.shtylyov@cogentembedded.com>,
	<yoshihiro.shimoda.uh@renesas.com>,
	<alexandre.belloni@free-electrons.com>,
	<thomas.petazzoni@free-electrons.com>, <zmxu@marvell.com>,
	<jszhang@marvell.com>, <linux-usb@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v6 0/7] usb: add support for the generic PHY framework
Date: Mon, 29 Sep 2014 09:24:50 +0800	[thread overview]
Message-ID: <20140929012449.GB26753@peterchendt> (raw)
In-Reply-To: <1411467122-21440-1-git-send-email-antoine.tenart@free-electrons.com>

On Tue, Sep 23, 2014 at 12:11:55PM +0200, Antoine Tenart wrote:
> Patches can also be found at:
> git://git.free-electrons.com:users/antoine-tenart/linux.git usb-phy
> 
> The series applies on top of Sergei generic PHY support in HCD[1]
> and on top of Peter Chen's ci-for-usb-next branch[2].
> 
> Thanks a lot!
> 
> Antoine
> 
> Changes since v5:
> 	- rebased on the latest version of Sergei's series[1]
> 	- fixed one modifiaction made in the wrong patch
> 
> Changes since v4:
>         - reworked the PHY handling in ci_hdrc_probe()
>         - fixed a rebase error
>         - rebased on top of [3]
> 
> Changes since v3:
>         - moved phy_exit() after phy_power_on()
>         - fixed the PHY handling in ci_hdrc_probe()
>         - some little fixes
> 
> Changes since v2:
>         - rebased the series on top of v3.17-rc1 (and [2])
>         - switched to devm_phy_get() to handle non DT cases
>         - moved usb_otg into the ci_hdrc structure
> 
> Changes since v1:
>         - rebased the series on top of [2] (generic PHY support for HCD)
>         - split s/phy/usb_phy/ renaming and generic PHY support in separate
>           patches
> 
> [1] https://www.mail-archive.com/linux-usb%40vger.kernel.org/msg48068.html
> [2] git://github.com/hzpeterchen/linux-usb.git ci-for-usb-next
> 
> Antoine Tenart (7):
>   usb: move the OTG state from the USB PHY to the OTG structure
>   usb: rename phy to usb_phy in OTG
>   usb: add support to the generic PHY framework in OTG
>   usb: allow to supply the PHY in the drivers when using HCD
>   usb: rename transceiver and phy to usb_phy in ChipIdea
>   usb: chipidea: move usb_otg into struct ci_hdrc
>   usb: chipidea: add support to the generic PHY framework in ChipIdea
> 
>  drivers/phy/phy-omap-usb2.c         | 14 ++----
>  drivers/usb/chipidea/ci.h           |  8 +++-
>  drivers/usb/chipidea/ci_hdrc_imx.c  |  2 +-
>  drivers/usb/chipidea/ci_hdrc_msm.c  |  8 ++--
>  drivers/usb/chipidea/core.c         | 89 ++++++++++++++++++++++++++--------
>  drivers/usb/chipidea/debug.c        |  2 +-
>  drivers/usb/chipidea/host.c         | 10 ++--
>  drivers/usb/chipidea/otg_fsm.c      | 30 +++++-------
>  drivers/usb/chipidea/udc.c          |  4 +-
>  drivers/usb/common/usb-otg-fsm.c    |  8 ++--
>  drivers/usb/core/hcd.c              |  7 +--
>  drivers/usb/host/ohci-omap.c        |  2 +-
>  drivers/usb/musb/am35x.c            | 28 +++++------
>  drivers/usb/musb/blackfin.c         | 18 +++----
>  drivers/usb/musb/da8xx.c            | 28 +++++------
>  drivers/usb/musb/davinci.c          | 18 +++----
>  drivers/usb/musb/musb_core.c        | 94 ++++++++++++++++++------------------
>  drivers/usb/musb/musb_dsps.c        | 26 +++++-----
>  drivers/usb/musb/musb_gadget.c      | 36 +++++++-------
>  drivers/usb/musb/musb_host.c        |  8 ++--
>  drivers/usb/musb/musb_virthub.c     | 22 ++++-----
>  drivers/usb/musb/omap2430.c         | 30 ++++++------
>  drivers/usb/musb/tusb6010.c         | 40 ++++++++--------
>  drivers/usb/musb/ux500.c            | 10 ++--
>  drivers/usb/phy/phy-ab8500-usb.c    | 16 +++----
>  drivers/usb/phy/phy-fsl-usb.c       | 23 ++++-----
>  drivers/usb/phy/phy-generic.c       |  6 +--
>  drivers/usb/phy/phy-gpio-vbus-usb.c | 14 +++---
>  drivers/usb/phy/phy-isp1301-omap.c  | 10 ++--
>  drivers/usb/phy/phy-msm-usb.c       | 95 +++++++++++++++++++------------------
>  drivers/usb/phy/phy-mv-usb.c        | 50 +++++++++----------
>  drivers/usb/phy/phy-samsung-usb2.c  |  2 +-
>  drivers/usb/phy/phy-tahvo.c         |  8 ++--
>  drivers/usb/phy/phy-ulpi.c          |  6 +--
>  include/linux/usb/chipidea.h        |  4 +-
>  include/linux/usb/otg.h             |  7 ++-
>  include/linux/usb/phy.h             |  1 -
>  37 files changed, 421 insertions(+), 363 deletions(-)
> 
> -- 
> 1.9.1
> 

Antoine, I am ok with your three chipidea patches, but when I go to
test it, I meet below error when I try to apply your 1st patch,
my branch is based on latest Greg's usb-next tree.

git am --3 patch_generic_phy_antoine/1.patch
Applying: usb: move the OTG state from the USB PHY to the OTG structure
fatal: sha1 information is lacking or useless (drivers/usb/host/ohci-omap.c).
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Patch failed at 0001 usb: move the OTG state from the USB PHY to the OTG structure
When you have resolved this problem run "git am --resolved".
If you would prefer to skip this patch, instead run "git am --skip".
To restore the original branch and stop patching run "git am --abort".

-- 
Best Regards,
Peter Chen

      parent reply	other threads:[~2014-09-29  1:25 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-09-23 10:11 [PATCH v6 0/7] usb: add support for the generic PHY framework Antoine Tenart
2014-09-23 10:11 ` [PATCH v6 1/7] usb: move the OTG state from the USB PHY to the OTG structure Antoine Tenart
2014-09-23 10:11 ` [PATCH v6 2/7] usb: rename phy to usb_phy in OTG Antoine Tenart
2014-09-23 10:11 ` [PATCH v6 3/7] usb: add support to the generic PHY framework " Antoine Tenart
2014-09-23 10:11 ` [PATCH v6 4/7] usb: allow to supply the PHY in the drivers when using HCD Antoine Tenart
2014-09-23 10:12 ` [PATCH v6 5/7] usb: rename transceiver and phy to usb_phy in ChipIdea Antoine Tenart
2014-09-23 10:12 ` [PATCH v6 6/7] usb: chipidea: move usb_otg into struct ci_hdrc Antoine Tenart
2014-09-23 10:12 ` [PATCH v6 7/7] usb: chipidea: add support to the generic PHY framework in ChipIdea Antoine Tenart
2014-09-29  1:24 ` Peter Chen [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140929012449.GB26753@peterchendt \
    --to=peter.chen@freescale.com \
    --cc=alexandre.belloni@free-electrons.com \
    --cc=antoine.tenart@free-electrons.com \
    --cc=balbi@ti.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jszhang@marvell.com \
    --cc=kishon@ti.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=sergei.shtylyov@cogentembedded.com \
    --cc=stern@rowland.harvard.edu \
    --cc=thomas.petazzoni@free-electrons.com \
    --cc=yoshihiro.shimoda.uh@renesas.com \
    --cc=zmxu@marvell.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox