From: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
To: Bas Peters <baspeters93@gmail.com>
Cc: Pushpendra Singh <pushpendra.singh@smartplayin.com>,
devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org,
gregkh@linuxfoundation.org, navin.patidar@gmail.com,
gmate.amit@gmail.com, manuel.schoelling@gmx.de
Subject: Re: [PATCH 2/6] staging: rtl8188eu: hal: removed code indent error
Date: Tue, 10 Feb 2015 20:18:44 +0530 [thread overview]
Message-ID: <20150210144844.GB16435@sudip-PC> (raw)
In-Reply-To: <CAOgR63foxcQtLaaS+vEQ2BKtgHGoQHn1xiLSv=4YZf=Dy6oG3w@mail.gmail.com>
On Tue, Feb 10, 2015 at 03:27:11PM +0100, Bas Peters wrote:
> >> @@ -101,8 +101,7 @@ void rtl88eu_phy_rf6052_set_cck_txpower(struct adapter *adapt, u8 *powerlevel)
> >> ptr++;
> >> }
> >> }
> >> - rtl88eu_dm_txpower_track_adjust(&hal_data->odmpriv, 1, &direction,
> >> - &pwrtrac_value);
> >> + rtl88eu_dm_txpower_track_adjust(&hal_data->odmpriv, 1, &direction, &pwrtrac_value);
> > you are introducing one warning to fix one error. line over 80 character.
>
> Isn't that warning more of a guideline, rather than an actual warning?
> This seems more readable than:
>
> - rtl88eu_dm_txpower_track_adjust(&hal_data->odmpriv, 1, &direction,
> - &pwrtrac_value);
> + rtl88eu_dm_txpower_track_adjust(&hal_data->odmpriv, 1,
> +
> &direction, &pwrtrac_value);
CodingStyle says "Statements longer than 80 columns will be broken into sensible chunks,
unless exceeding 80 columns significantly increases readability and does not hide information"
i agree that this is more readable but can it be called significant improvement ? but ofcourse final decision is on Greg.
sudip
>
> Bas
next prev parent reply other threads:[~2015-02-10 14:48 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-02-10 13:02 [PATCH 1/6] staging: rt8188eu: hal: removed space before ',' Pushpendra Singh
2015-02-10 13:02 ` [PATCH 2/6] staging: rtl8188eu: hal: removed code indent error Pushpendra Singh
2015-02-10 14:13 ` Sudip Mukherjee
2015-02-10 14:27 ` Bas Peters
2015-02-10 14:48 ` Sudip Mukherjee [this message]
2015-02-11 8:33 ` Dan Carpenter
2015-02-11 9:40 ` Joe Perches
2015-02-11 10:51 ` Dan Carpenter
2015-02-11 18:00 ` checkpatch induced patches Joe Perches
2015-02-11 18:36 ` Dan Carpenter
2015-02-11 20:02 ` Richard Weinberger
2015-02-11 20:20 ` Joe Perches
2015-02-11 20:24 ` Pavel Machek
2015-02-11 20:43 ` Joe Perches
2015-02-11 22:43 ` Dan Carpenter
2015-02-11 22:46 ` Richard Weinberger
2015-02-11 23:01 ` Joe Perches
2015-02-12 8:03 ` Sudip Mukherjee
2015-02-12 16:44 ` Kalle Valo
2015-02-10 22:25 ` [PATCH 2/6] staging: rtl8188eu: hal: removed code indent error Greg KH
2015-02-10 13:02 ` [PATCH 3/6] staging: rtl8188eu: hal: removed unnecessary braces Pushpendra Singh
2015-02-10 13:02 ` [PATCH 4/6] staging: rtl8188eu: hal: added blank line after declarations Pushpendra Singh
2015-02-10 13:02 ` [PATCH 5/6] staging: rtl8188eu: hal: removed spaces at start of line Pushpendra Singh
2015-02-10 13:02 ` [PATCH 6/6] staging: rtl8188eu: hal: removed unnecessary parentheses Pushpendra Singh
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150210144844.GB16435@sudip-PC \
--to=sudipm.mukherjee@gmail.com \
--cc=baspeters93@gmail.com \
--cc=devel@driverdev.osuosl.org \
--cc=gmate.amit@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=manuel.schoelling@gmx.de \
--cc=navin.patidar@gmail.com \
--cc=pushpendra.singh@smartplayin.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox