From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754155AbbCXTZ4 (ORCPT ); Tue, 24 Mar 2015 15:25:56 -0400 Received: from mail.skyhub.de ([78.46.96.112]:49169 "EHLO mail.skyhub.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752756AbbCXTZz (ORCPT ); Tue, 24 Mar 2015 15:25:55 -0400 Date: Tue, 24 Mar 2015 20:24:10 +0100 From: Borislav Petkov To: Ingo Molnar Cc: Denys Vlasenko , Andy Lutomirski , Linus Torvalds , Steven Rostedt , "H. Peter Anvin" , Oleg Nesterov , Frederic Weisbecker , Alexei Starovoitov , Will Drewry , Kees Cook , x86@kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] x86/asm/entry/64: Rename THREAD_INFO() to ASM_ASM_THREAD_INFO_MEMOP() Message-ID: <20150324192410.GE11525@pd.tnic> References: <1426785469-15125-1-git-send-email-dvlasenk@redhat.com> <20150324184442.GC14760@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <20150324184442.GC14760@gmail.com> User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Mar 24, 2015 at 07:44:42PM +0100, Ingo Molnar wrote: > From 234ed7356ecfa60f4e209d513d89fa9de41aa4c5 Mon Sep 17 00:00:00 2001 > From: Ingo Molnar > Date: Tue, 24 Mar 2015 19:29:16 +0100 > Subject: [PATCH] x86/asm/entry/64: Rename THREAD_INFO() to ASM_ASM_THREAD_INFO_MEMOP() > > The THREAD_INFO() macro has a somewhat confusingly generic name, defined in > a generic .h C header file. It also does not make it clear that it constructs > a memory operand for use in assembly code. > > Rename it to ASM_THREAD_INFO_MEMOP() to make it all glaringly obvious on > first glance. Why the MEMOP? ASM_THREAD_INFO() looks pretty enough to me. :) -- Regards/Gruss, Boris. ECO tip #101: Trim your mails when you reply. --