From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753272AbbIKPzn (ORCPT ); Fri, 11 Sep 2015 11:55:43 -0400 Received: from mail-pa0-f51.google.com ([209.85.220.51]:35815 "EHLO mail-pa0-f51.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753020AbbIKPzm (ORCPT ); Fri, 11 Sep 2015 11:55:42 -0400 Date: Sat, 12 Sep 2015 00:52:22 +0900 From: Namhyung Kim To: =?utf-8?B?5bmz5p2+6ZuF5bezIC8gSElSQU1BVFXvvIxNQVNBTUk=?= Cc: Arnaldo Carvalho de Melo , Ingo Molnar , Peter Zijlstra , Jiri Olsa , LKML , Wang Nan Subject: Re: [PATCH 3/3] perf probe: Move init/exit_probe_symbol_maps() into callers Message-ID: <20150911155222.GA3447@danjae.kornet> References: <1441852026-28974-1-git-send-email-namhyung@kernel.org> <1441852026-28974-3-git-send-email-namhyung@kernel.org> <50399556C9727B4D88A595C8584AAB37525215FC@GSjpTKYDCembx32.service.hitachi.net> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: <50399556C9727B4D88A595C8584AAB37525215FC@GSjpTKYDCembx32.service.hitachi.net> User-Agent: Mutt/1.5.23+102 (2ca89bed6448) (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Sep 10, 2015 at 12:58:59PM +0000, 平松雅巳 / HIRAMATU,MASAMI wrote: > > >From: Namhyung Kim [mailto:namhyung@gmail.com] On Behalf Of Namhyung Kim > >The init/exit_probe_symbol_maps() was a part of > >convert_perf_probe_events() and cleanup_perf_probe_events(). But as > >these functions can be called multiple times, it'd be better moving > >init/exit functions out of them, so that it should be called only once. > > Ah, OK, I see. > But I'd rather like exposing prototypes in this patch, since this is the true > user of it. I'm fine with merging 2/3 and 3/3. Arnaldo, could you do this or do you want me to resend? Thanks, Namhyung