From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755825AbbLGJyd (ORCPT ); Mon, 7 Dec 2015 04:54:33 -0500 Received: from mail.skyhub.de ([78.46.96.112]:51131 "EHLO mail.skyhub.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755779AbbLGJyb (ORCPT ); Mon, 7 Dec 2015 04:54:31 -0500 Date: Mon, 7 Dec 2015 10:54:20 +0100 From: Borislav Petkov To: Ingo Molnar Cc: LKML Subject: Re: [PATCH 3/4] x86/cpufeature: Remove unused and seldomly used cpu_has_xx macros Message-ID: <20151207095420.GB22248@pd.tnic> References: <1449481182-27541-1-git-send-email-bp@alien8.de> <1449481182-27541-4-git-send-email-bp@alien8.de> <20151207094504.GA27386@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <20151207094504.GA27386@gmail.com> User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Dec 07, 2015 at 10:45:04AM +0100, Ingo Molnar wrote: > > * Borislav Petkov wrote: > > > static int __init chacha20_simd_mod_init(void) > > { > > - if (!cpu_has_ssse3) > > + if (!boot_cpu_has(X86_FEATURE_SSSE3)) > > return -ENODEV; > > Btw., could we rename 'boot_cpu_has()' to the more appropriate (and shorter!) > 'system_has()' form? > > 'boot cpu' is a conceptual misnomer here really: it's just an implementational > detail that we are looking at the boot CPU's flags, what we really mean to express > is that these are system-wide features with no per-cpu properties. > > Agreed? Yeah, sounds good to me. Mind if I do it for the next part of the cleanup, though, and not rework those patches which are already tested? I have a bunch of bulletpoints on the TODO still and could take care of the renaming then too. Thanks. -- Regards/Gruss, Boris. ECO tip #101: Trim your mails when you reply.