From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755395AbbLVQUH (ORCPT ); Tue, 22 Dec 2015 11:20:07 -0500 Received: from mail-pf0-f173.google.com ([209.85.192.173]:33258 "EHLO mail-pf0-f173.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755218AbbLVQUE (ORCPT ); Tue, 22 Dec 2015 11:20:04 -0500 Date: Wed, 23 Dec 2015 01:19:17 +0900 From: Namhyung Kim To: Jiri Olsa Cc: Arnaldo Carvalho de Melo , Ingo Molnar , Peter Zijlstra , LKML , David Ahern , Steven Rostedt , Frederic Weisbecker , Andi Kleen , Wang Nan Subject: Re: [PATCH 08/10] perf tools: Add --raw-trace option Message-ID: <20151222161917.GC4508@danjae.kornet> References: <1450193743-4409-1-git-send-email-namhyung@kernel.org> <1450193743-4409-9-git-send-email-namhyung@kernel.org> <20151220145842.GA18893@krava.brq.redhat.com> <20151221084441.GB22464@danjae.kornet> <20151222065712.GB13404@krava.brq.redhat.com> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <20151222065712.GB13404@krava.brq.redhat.com> User-Agent: Mutt/1.5.24 (2015-08-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Dec 22, 2015 at 07:57:12AM +0100, Jiri Olsa wrote: > On Mon, Dec 21, 2015 at 05:44:41PM +0900, Namhyung Kim wrote: > > SNIP > > > > > > > I think the default is good with the 'trace' sort key as it is now: > > > > > > $ ./perf report -s trace > > > 27.01% offlineimap:17701 [120] S ==> swapper/1:0 [120] > > > 27.00% swapper/1:0 [120] R ==> offlineimap:17701 [120] > > > > > > > > > But for '--raw-trace' option rather than displaying fields in the '=' notation: > > > > > > $ ./perf report -s trace --raw-trace > > > 27.01% prev_comm=offlineimap prev_pid=17701 prev_prio=120 prev_state=1 next_comm=swapper/1 next_pid=0 next_prio=120 > > > 27.00% prev_comm=swapper/1 prev_pid=0 prev_prio=120 prev_state=0 next_comm=offlineimap next_pid=17701 next_prio=120 > > > > > > > > > it would be more readable to register all available columns as is possible to do now with: > > > > > > $ ./perf report -s prev_comm,prev_pid,prev_prio,prev_state,next_comm,next_pid,next_prio > > > Overhead prev_comm prev_pid prev_prio prev_state next_comm next_pid next_prio > > > 27.01% offlineimap 17701 120 1 swapper/1 0 120 > > > 27.00% swapper/1 0 120 0 offlineimap 17701 120 > > > > > > > > > it would be default output for 'perf report -s trace --raw-trace' command > > > > > > how about that? > > > > > > I agree with the latter is much more readable. But the dynamic sort > > keys are event specific while 'trace' is generic. So if there are > > more than one events, dynamic sort keys should be generated for each > > event and they'll show "N/A" for other events. > > I see.. haven't realized that, maybe we should add > columns based in the hists object.. but I guess > that's out of scope of this patchset ;-) Right. On a second thought, I can make it skip dynamic fields if they're for other event. Then we don't need to maintain per-event sort keys IMHO. > > > > > Also I don't like the --raw-trace option affects number of sort keys. > > Maybe it'd be better adding 'EVENT.*' dynamic sort key for your case? > > that's good workaround, thanks With above trick, I think I can add all dynamic fields automatically as default sort key when --raw-trace is given as you said. Will try. Thanks, Namhyung